输入整型数组和排序标识,对其元素按照升序或降序进行排序

描述

输入整型数组和排序标识,对其元素按照升序或降序进行排序

接口说明

原型:

void sortIntegerArray(Integer[] pIntegerArray, int iSortFlag);

输入参数:

    Integer[] pIntegerArray:整型数组

int  iSortFlag:排序标识:0表示按升序,1表示按降序

输出参数:

    无

返回值:

    void


知识点 循环,排序,数组
运行时间限制 10M
内存限制 128
输入

1、输入需要输入的整型数个数

2、输入数组组

3、输入排序标识


输出

输出排好序的数字

最后一个无空格

如下例子


样例输入 8 1 2 4 9 3 55 64 25 0
样例输出 1 2 3 4 9 25 55 64
#include <iostream>
#include <string>
#include <vector>
#include<iomanip>
#include <algorithm>
using namespace std;

bool cmp1(const int &a,const int &b)
{
	return(a<b);
}
bool cmp2(const int &a,const int &b)
{
	return(a>b);
}
int main()
{
	int n;
	cin>>n;
	vector<int> a;
	int value;
	for (int i=0;i<n;i++)
	{
		cin>>value;
		a.push_back(value);
	}
	int flag;
	cin>>flag;
	if (flag==0)
	{
		sort(a.begin(),a.end(),cmp1);
	} 
	else
	{
		sort(a.begin(),a.end(),cmp2);
	}
	for (int i=0;i<n;i++)
	{
		if (i!=n-1)
		{
			cout<<a.at(i)<<" ";
		}	
		else
		{
			cout<<a.at(i);
		}
		
	}
	cout<<endl;
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值