HDOJ 游船出租 1861

游船出租

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7748    Accepted Submission(s): 2571


Problem Description
现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和
平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。
 

Input
测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。
 

Sample Input
  
  
1 S 08:10 2 S 08:35 1 E 10:00 2 E 13:16 0 S 17:00 0 S 17:00 3 E 08:10 1 S 08:20 2 S 09:00 1 E 09:20 0 E 17:00 -1
 

Sample Output
  
  
2 196 0 0 1 60
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1862  1864  1877  1881  1230

看错答案。。醉了。。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
struct minute{
    friend bool operator < (minute n1, minute n2)  
    {  
        return n1.num < n2.num;  
    }  
	int num,h,m;
};
int main()
{
    int t;
    priority_queue<minute>s;
    priority_queue<minute>e;
    char key;
    int star,en;
    int hh,mm;
    minute temp;
	int p=0;
    while(scanf("%d",&t)!=EOF){
        if(t==-1)break;
        getchar();
        scanf("%c%d:%d",&key,&hh,&mm);
        if(t==0){
            int cou=0,xp=0;
            if(p==0){
            	printf("0 0\n");
            	while(!e.empty())e.pop();
        		while(!s.empty())s.pop();
			}
            else{
            	p=0;
            	while(!s.empty()){
                    minute t1=s.top(),t2=e.top();
                    if(t1.num>t2.num){
                    	s.pop();continue;
					}
					if(t1.num<t2.num){
						e.pop();continue;
					}
                	cou+=(t2.h-t1.h)*60+(t2.m-t1.m);
                	s.pop(),e.pop();
                	xp++;
                }
                if(xp==0){
                	printf("0 0\n");
                	while(!e.empty())e.pop();
        			while(!s.empty())s.pop();
				}
                else{
                	printf("%d %.0lf\n",xp,(double)cou/xp);
                	while(!e.empty())e.pop();
        			while(!s.empty())s.pop();
				}	
			}
        }
        else{
        	p=1;
        	temp.num=t,temp.h=hh,temp.m=mm;
            if(key=='S')
            s.push(temp);
            else if(key=='E')
            e.push(temp);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值