hdu1058

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23099 Accepted Submission(s): 10082

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal(顺序的) number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source
University of Ulm Local Contest 1996

本题思路很简单:就是用2,3,5,7循环来
求第i个f[i],第i个f[i]必定等于
前i-1个数中其中一个数与{2,3,5,7}中
其中一个的乘积,于是答案就出来了,就是取从1开始取与2,3,5,7相乘,去最小的,取了一个对应指针就往前移一位

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int min(int x,int y){
    return x<y?x:y;
}
int dp[5843];
int main(){
    int n,a,b,c,d;
    a=b=c=d=1;
    dp[1]=1;
    for (int i = 2; i <= 5842; ++i)
    {
        dp[i]=min(dp[a]*2,min(dp[b]*3,min(dp[c]*5,dp[d]*7)));
        if(dp[i] == dp[a]*2)++a;
        if(dp[i] == dp[b]*3)++b;
        if(dp[i] == dp[c]*5)++c;
        if(dp[i] == dp[d]*7)++d;

    }
    while(scanf("%d",&n)!=EOF&&n){//The 1000th humble number is 385875.
        printf("The %d",n);
        if(n%10==1&&n%100!=11)printf("st ");
        else if(n%10==2&&n%100!=12)printf("nd ");
        else if(n%10==3&&n%100!=13)printf("rd ");
        else printf("th ");
        printf("humble number is %d.\n", dp[n]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值