XTU 1207 Welcome to XTCPC

Welcome to XTCPC

   
Time Limit : 1000 MS Memory Limit : 65536 KB 

Problem Description

Welcome to XTCPC! XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not. Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases. For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input
3
XTCPC
CCC
XXXXTTTTCCCCPPPCCC


Sample Output
Case 1: Yes
Case 2: No
Case 3: Yes
#include<stdio.h>
#include<string.h>
char a[10000010];
int main()
{
    char b[10];
    b[0] = 'X';
    b[1] = 'T';
    b[2] = 'C';
    b[3] = 'P';
    b[4] = 'C';
    int n = 0,i,j;
    int m;
    int T;
    int pp = 0;
    scanf("%d",&T);
    while(T--)
    {
        pp++;
        scanf("%s",a);
        n = 0;
        n = strlen(b);
        j = 0;
        for(i=0;a[i]!='\0';i++)
        {
            if(a[i] == b[j])
            {
                j++;
            }
        }
        if(== n)
        {
            printf("Case %d: Yes\n",pp);
        }
        else
        {
            printf("Case %d: No\n",pp);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值