Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 44220 | Accepted: 13814 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Output
Sample Input
5 17
Sample Output
4
Hint
Source
大致题意:
给定两个整数n和k
通过 n+1或n-1 或n*2 这3种操作,使得n==k
输出最少的操作次数
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
int x,ans;
}q[1000005];
int jx[]={-1,1};
int n,k;
int v[1000005];
void BFS()
{
struct node t,f;
int i;
int e=0,s=0;
t.x=n;
v[t.x]=1;
t.ans=0;
q[e++]=t;
while(s<e)
{
t=q[s++];
if(t.x==k)
{
printf("%d\n",t.ans);
break;
}
for(i=0;i<3;i++)
{
if(i==2)
f.x=t.x*2;
else f.x=t.x+jx[i];
if(v[f.x]==0&&f.x>=0&&f.x<=100000)
{
f.ans=t.ans+1;
q[e++]=f;
v[f.x]=1;
}
}
}
}
int main()
{
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(v,0,sizeof(v));
BFS();
}
return 0;
}