POJ 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44220 Accepted: 13814

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source



大致题意:

给定两个整数nk

通过 n+1n-1 n*2 3种操作,使得n==k

输出最少的操作次数


 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int x,ans;
}q[1000005];
int jx[]={-1,1};
int n,k;
int v[1000005];
void BFS()
{
     struct node t,f;
     int i;
     int e=0,s=0;
     t.x=n;
     v[t.x]=1;
     t.ans=0;
     q[e++]=t;
     while(s<e)
    {
        t=q[s++];
        if(t.x==k)
        {
             printf("%d\n",t.ans);
             break;
        }
        for(i=0;i<3;i++)
        {
             if(i==2)
             f.x=t.x*2;
             else f.x=t.x+jx[i];
             if(v[f.x]==0&&f.x>=0&&f.x<=100000)
             {
                 f.ans=t.ans+1;
                 q[e++]=f;
                 v[f.x]=1;
             }
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(v,0,sizeof(v));
        BFS();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值