HDU 1061 Rightmost Digit

A - Rightmost Digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output

For each test case, you should output the rightmost digit of N^N.
 

Sample Input

     
     
2 3 4
 

Sample Output

     
     
7 6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stdlib.h>

using namespace std;

int mod(int n,int m,int a)
{
    if(m == 0)
    {
        return 1;
    }
    int x = mod(n,m/2,a);
    long long ans = (long long)x * x %a;
    if(m%2 == 1)
    {
        ans = ans * n % a;
    }
    return (int)ans;
}

int main()
{
    int n,i,j;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int pp;
        pp = mod(n,n,10);
        pp = pp % 10;
        printf("%d\n",pp);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值