HDU 1505 UVALive 3029 City Game

City Game
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input file contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R – reserved unit 
F – free unit
In the end of each area description there is a separating line.

Output

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0
 
   
 
   
 
   
 
   
 
   
 
   
#include <cstdio>
#include <algorithm>
#define LL long long
using namespace std;
const int maxn = 1001;

int mat[maxn][maxn], up[maxn][maxn], le[maxn][maxn], rig[maxn][maxn];
int main()
{
    int t, ans;
    int m, n, i, j, lo, ro;
    scanf("%d",&t);
    while(t--)
    {
        ans = 0;
        scanf("%d%d", &m, &n);
        for(i = 0; i < m; i++)
        {
            for(j = 0; j < n; j++)
            {
                char ch = getchar();
                while(ch!='F'&&ch!='R')
                {
                    ch = getchar();
                }
                mat[i][j] = ch == 'F' ?0:1;

            }
        }
        for(i = 0; i < m; i++)
        {
            lo = -1;
            ro = n;
            for(j = 0; j < n; j++)
            {
                if(mat[i][j] == 1)
                {
                    //le数组存储的是矩形的左边界
                    up[i][j] = le[i][j] = 0;//up数组存储的是上边界,相当于长方形的宽
                    lo = j;
                }
                else
                {
                    up[i][j] = i == 0?1:up[i-1][j] + 1;
                    le[i][j] = i == 0 ? lo+1 : max(le[i-1][j], lo+1);
                }
            }

            for(j = n-1; j >= 0; j--)
            {
                if(mat[i][j] == 1)
                {//rig存储的是矩形的右边界
                    rig[i][j] = n;
                    ro = j;

                }
                else
                {
                    //rig[i][j] - le[i][j]得到的是矩形的长
                    rig[i][j] = i ==0 ? ro-1 : min(rig[i-1][j], ro-1);
                    ans = max(ans, up[i][j]*(rig[i][j]-le[i][j]+1)); //他们的乘积是子矩形的面积
                }
            }

        }
        
        printf("%d\n", ans*3);

    }
    return 0;

}

 
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值