POJ 1125 Stockbroker Grapevine(多源求最短路)

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27338 Accepted: 15143

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.  

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.  

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.  

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.  
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001


        题目大意:有n个股票经济人,他们可以相互透漏消息,而且前提是单方向的传递消息。现在有一个消息需要让这n个股票经济人都知道,问有没有可以担当这个传递消息的人。如果有多个人符合要求就求出时间最短的那个人。如果没有就输出"disjoint""

        首先用floyd算法把所有的存在的最短路径求出来,求出来之后对每一个股票经济人进行判断,判断是否可以作为传递消息的人,如果该股票经济人可以把消息传递给所有的人,那就把他传递的消息中用时最长的那个时间与ans作比较,(ans为当时的最小时间)。求符合要求的股票经济人pp和其最短的时间ans


#include<iostream>
#include<stdlib.h>
#include<string.h>
#include<algorithm>

using namespace std;

const int INF = 9999999;
const int N = 200;

int map[N][N];
int n,m;

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(map[i][j] > (map[i][k] + map[k][j]))
                {
                    map[i][j] = map[i][k] + map[k][j];
                }
            }
        }
    }
}

int main()
{
    int T,t;
    while(cin >> n)
    {
        if(n == 0)
        {
            break;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                map[i][j] = INF;//初始化
            }
            map[i][i] = 0;
        }
        int x,y;
        for(int i=1;i<=n;i++)
        {
            cin >> m;
            for(int j=1;j<=m;j++)
            {
                cin >> x >>y;
                map[i][x] = y;//更新
            }
        }
        floyd();
        int ans,min,pp;
        int flag;
        ans = INF;
        for(int i=1;i<=n;i++)
        {
            min = -1;
            for(int j=1;j<=n;j++)
            {
                if(i!=j && map[i][j]>min)
                {
                    min = map[i][j];
                }
            }
           
            if(min < ans)
            {
                ans = min;//更新ans的值
                pp = i;
            }
        }
        if(ans == INF)
        {
            cout << "disjoint" << endl;
        }
        else
        {
            cout << pp << " " << ans << endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值