POJ2240 Arbitrage(最短路)

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15991 Accepted: 6737

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source




      题目大意:求一笔钱经过各种货币之间的兑换,最后兑换回原来的货币是否会增值,增值的话输出Yes,否则输出No.

      先初始化map数组为0,(其中map[i][i] = 1(自身兑换自身汇率为1)),最后用弗洛伊德算法更新map数组,然后遍历map[i][i]的权值是否大于1,如果大于1就说明增值了。


弗洛伊德算法:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<string>
#include<algorithm>

using namespace std;
const int N = 10001;
string name[1000];
int n,m;
double map[N][N];

int findd(string aa)
{
    for(int i=0;i<n;i++)
    {
        if(aa == name[i])
        {
            return i;
        }
    }
}

int floyd()
{
    for(int k=0;k<n;k++)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(map[i][j] < map[i][k]*map[k][j])
                {
                    map[i][j] = map[i][k]*map[k][j];
                }
            }
        }
    }
    for(int i=0;i<n;i++)
    {
        if(map[i][i] > 1)
        {
            return 1;
        }
    }
    return 0;
}

int main()
{
    int k = 0;
    while(cin >> n)
    {
        if(n == 0)
        {
            break;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                map[i][j] = 0;
            }
            map[i][i] = 1;
        }
        getchar();
        for(int i=0;i<n;i++)
        {
            cin >> name[i];
        }
        cin >> m;
        string name1,name2;
        double mm;
        getchar();
        for(int i=0;i<m;i++)
        {
            cin >> name1 >> mm >> name2;
            int a,b;
            a = findd(name1);
            b = findd(name2);
            map[a][b] = mm;
        }
        int pp = floyd();
        if(pp == 1)
        {
            cout << "Case " << ++k << ": Yes" << endl;
        }
        else
        {
            cout << "Case " << ++k << ": No" << endl;
        }
    }
    return 0;
}








贝尔曼福特算法:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>

using namespace std;

int n,m;
string name[10000];
int t;
double num[100010];

struct node
{
    int x,y;
    double z;
}q[1000010];

void add(int x,int y,double p)
{
    q[t].x = x;
    q[t].y = y;
    q[t++].z = p;
}

int findd(string aa)
{
    for(int i=0;i<n;i++)
    {
        if(aa == name[i])
        {
            return i;
        }
    }
}
int BF()
{
    for(int i=0;i<n;i++)
    {
        num[i] = 0;
    }
    num[0] = 1;
    for(int i=0;i<t;i++)
    {
        int flag = 0;
        for(int j=0;j<t;j++)
        {
            if(num[q[j].y] < num[q[j].x] * q[j].z)
            {
                num[q[j].y] = num[q[j].x] * q[j].z;
            }
        }
    }
    for(int i=0;i<t;i++)
    {
        if(num[q[i].y] < num[q[i].x] * q[i].z)
        {
            return 1;
        }
    }
    return 0;
}

int main()
{
    int k = 0;
    while(cin >> n)
    {
        t = 0;
        if(n == 0)
        {
            break;
        }
        getchar();
        for(int i=0;i<n;i++)
        {
            cin >> name[i];
        }
        string name1,name2;
        double mm;
        cin >> m;
        getchar();
        for(int i=0;i<m;i++)
        {
            cin >> name1 >> mm >> name2;
            int a = findd(name1);
            int b = findd(name2);
            add(a,b,mm);
        }
        int pp = BF();
        if(pp == 1)
        {
            cout << "Case " << ++k << ": Yes" << endl;
        }
        else
        {
            cout << "Case " << ++k << ": No" << endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值