Cube painting
Cube painting |
We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.
Figure 1.
Since a cube has 6 faces, our machine can paint a face-numbered cube in different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a b, r, or g. The character ( ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 , the one changes into the other.
Input
The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)
Output
The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.
Sample Input
rbgggrrggbgr rrrbbbrrbbbr rbgrbgrrrrrg
Sample Output
TRUE FALSE FALSE
题意:输入一个长度为12的字符串,前6个字符和后6个字符分别代表两个正方体的6个面,问第一个正方体是否可以通过一个轴(1和6 2和5 3和4)翻转。翻成第二个正方体。能的话输出TRUE 否则输出FALSE
本来用BFS写,写着写着忘怎么写,也是醉了,只好暴力枚举
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
char x;
char y;
} a,b,c;
int findd(char up,char down,char aa,char bb,char cc,char dd)
{
if(up == a.x && down == a.y && aa == b.x && bb == b.y && cc == c.x && dd == c.y)
{
return 1;
}
if(up == a.x && down == a.y && bb == b.x && aa == b.y && dd == c.x && cc == c.y)
{
return 1;
}
if(up == a.x && down == a.y && cc == b.x && dd == b.y && aa == c.x && bb == c.y)
{
return 1;
}
if(up == a.x && down == a.y && dd == b.x && cc == b.y && bb == c.x && aa == c.y)
{
return 1;
}
return 0;
}
int main()
{
char map[15];
while(scanf("%s",map)!=EOF)
{
a.x = map[6];
a.y = map[11];
b.x = map[7];
b.y = map[10];
c.x = map[8];
c.y = map[9];
int p1 = findd(map[0],map[5],map[1],map[4],map[2],map[3]);
int p2 = findd(map[1],map[4],map[2],map[3],map[0],map[5]);
int p3 = findd(map[2],map[3],map[1],map[4],map[5],map[0]);
int p4 = findd(map[3],map[2],map[1],map[4],map[0],map[5]);
int p5 = findd(map[4],map[1],map[3],map[2],map[0],map[5]);
int p6 = findd(map[5],map[0],map[1],map[4],map[3],map[2]);
if(p1+p2+p3+p4+p5+p6)
{
printf("TRUE\n");
}
else
{
printf("FALSE\n");
}
}
return 0;
}
Cube painting
Cube painting |
We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.
Figure 1.
Since a cube has 6 faces, our machine can paint a face-numbered cube in different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a b, r, or g. The character ( ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 , the one changes into the other.
Input
The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)
Output
The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.
Sample Input
rbgggrrggbgr rrrbbbrrbbbr rbgrbgrrrrrg
Sample Output
TRUE FALSE FALSE