SDUT 1351 Max Sum

Max Sum

Time Limit: 2000ms   Memory limit: 32768K  有疑问?点这里^_^

题目描述

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

输出

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

示例输入

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

示例输出

Case 1:
14 1 4

Case 2:
7 1 6

提示

hdoj1003 注意:本题后台测试数据量比较大,请使用C语言scanf输入。避免超时!!!!

来源

Ignatius.L




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>

using namespace std;

int a[100100],b[100100];

int main()
{
    int T;
    int k = 0;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        b[0] = a[0];
        for(int i=1;i<n;i++)
        {
            if(b[i-1]<0)
            {
                b[i] = a[i];
            }
            else
            {
                b[i] = a[i] + b[i-1];
            }
        }
        int xx,yy;
        int maxx = -999999;
        for(int i=0;i<n;i++)
        {
            if(maxx<b[i])
            {
                maxx = b[i];
                yy = i+1;
            }
        }
        int pmax = 0;
        for(int i=yy-1;i>=0;i--)
        {
            pmax += a[i];
            //printf("pmax = %d   maxx = %d\n",pmax,maxx);
            if(pmax == maxx)
            {
                xx = i+1;
               // break;
            }
        }
        printf("Case %d:\n",++k);
        printf("%d %d %d\n",maxx,xx,yy);
        if(T)
        {
            printf("\n");
        }
    }
    return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值