HDU 1010 Tempter of the Bone(深搜)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86037    Accepted Submission(s): 23462


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author
ZHANG, Zheng
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1016  1242  1072  1312  1026 




好久没有做搜索方面的题目,手贱做了一下,简单的一个这样的题都能错几遍,也是没谁了。


     题意:一个n*m的矩阵,老鼠的起点在矩阵中的'S'上,终点在矩阵中的'D',其中'X'是墙,老鼠不能通过,'.'是路但是只能通过一次,过了一次之后就不能再走这个地方了,终点D在第K秒是打开,这就要求老鼠能够在第K秒是正好到达D点,如果不能就输出NO,可以的话就输出YES.
     不过这个题做的话需要剪枝,如果不剪枝就会超时。至于剪枝可以通过起点与终点的最短距离与要求的时间K同奇偶的特性来进行判断。同奇偶性是指起点与终点是确定的,所以在不考虑中间有没有墙的情况下有一个最短的距离,这个距离的奇偶性如果与要求的K的奇偶性不相同的话,那他绝对不可能到达。不信的话可以试试。



代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>

using namespace std;

int n,m,k;
char map[9][9];
bool v[9][9];
int jx[] = {0,1,0,-1};
int jy[] = {1,0,-1,0};
int x2,y2;
int pf;
int p;

void DFS(int xx,int yy,int cnt)
{
    if(xx == x2 && yy ==y2 && cnt == k)
    {
        pf = 1;
        return ;
    }
    if(pf == 1)
    {
        return ;
    }
    for(int i=0;i<4;i++)
    {
        int fx = xx + jx[i];
        int fy = yy + jy[i];
        int ans = abs(x2 - fx) + abs(y2 - fy);
        if((1+cnt+ans<=k) && (1+cnt+ans)%2 == p && fx>=0 && fx<n && fy>=0 && fy<m && map[fx][fy]!='X' && v[fx][fy] == 0)
        {
            v[fx][fy] = 1;
            DFS(fx,fy,cnt+1);
            v[fx][fy] = 0;
        }
    }
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        memset(v,0,sizeof(v));
        if(n == 0 && m == 0 && k == 0)
        {
            break;
        }
        p = k%2;
        pf = 0;
        int x1,y1;
        for(int i=0;i<n;i++)
        {
            getchar();
            for(int j=0;j<m;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j] == 'S')
                {
                    x1 = i;
                    y1 = j;
                }
                else if(map[i][j] == 'D')
                {
                    x2 = i;
                    y2 = j;
                }
            }
        }
        getchar();
        int pans = abs(y2 - y1) + abs(x2 - x1);
        if(pans>k || pans%2!=p)
        {
            printf("NO\n");
            continue;
        }
        v[x1][y1] = 1;
        DFS(x1,y1,0);
        if(pf == 1)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}


 

  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值