HDU 5289 Assignment(多校联合第一场1002)

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617    Accepted Submission(s): 314


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,k;
int a[100100];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        __int64 sum = 0;
        scanf("%d%d",&n,&k);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int bmax,bmin;
        for(int i=0; i<n; i++)
        {
            int max = a[i],min = a[i];
            bmax = i;
            bmin = i;
            int j;
            for(j=i; j<n; j++)
            {
                if(max<a[j])
                {
                    bmax = j;
                    max = a[j];
                }
                if(min > a[j])
                {
                    bmin = j;
                    min = a[j];
                }
                if(max-min >=k)
                {
                    int k2 = 1;
                    int k1 = 1;
                    if(bmax>bmin)
                    {
                        for(int v=i; v<bmax; v++)
                        {
                            sum += k1++;
                        }
                        for(int v=bmin+1;v<bmax;v++)
                        {
                            sum -= k2++;
                        }
                        i = bmin;
                    }
                    else
                    {
                        for(int v=i; v<bmin; v++)
                        {
                            sum += k1++;
                        }
                        for(int v=bmax+1;v<bmin;v++)
                        {
                            sum -= k2++;
                        }
                        i = bmax;
                    }
                    break;
                }
            }
            if(j == n)
            {
                int pk = 1;
                for(int v=i;v<n;v++)
                {
                    sum += pk++;
                }
                i = n;
                break;
            }
        }
        printf("%I64d\n",sum);
    }
    return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值