POJ 1850 Code(组合数学)

Code
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8662 Accepted: 4113

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source





      题意:给一个字符串,求这个字符串排第几? 换句话说输出某个str字符串在字典中的位置,由于字典是从a=1开始的,因此str的位置值就是 在str前面所有字符串的个数 +1规定输入的字符串必须是升序排列。不降序列是非法字符串



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int c[27][27] = {0};

void updata()
{
    for(int i=0;i<=26;i++)
    {
        for(int j=0;j<=i;j++)
        {
            if(j == 0 || i == j)
            {
                c[i][j] = 1;
            }
            else
            {
                c[i][j] = c[i-1][j-1] + c[i-1][j];
            }
        }
    }
    c[0][0] = 0;
}

int main()
{
    char str[20];
    updata();
    while(scanf("%s",str)!=EOF)
    {
        int len = strlen(str);
        for(int i=0;i<len-1;i++)
        {
            if(str[i]>=str[i+1])
            {
                printf("0\n");
                return 0;
            }
        }
        int sum = 0;
        for(int i=1;i<len;i++)
        {
            sum += c[26][i];
        }
        for(int i=0;i<len;i++)
        {
            char ch = (i)?str[i-1]+1:'a';
            while(ch<=str[i]-1)
            {
                sum += c['z'-ch][len-1-i];
                ch++;
            }
        }
        sum += 1;
        printf("%d\n",sum);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值