HDU 5311 Sequence

Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 803    Accepted Submission(s): 302


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string  s  of length  n . He wants to find three nonoverlapping substrings  s[l1..r1] s[l2..r2] s[l3..r3]  that:

1.  1l1r1<l2r2<l3r3n

2. The concatenation of  s[l1..r1] s[l2..r2] s[l3..r3]  is "anniversary".
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T100) , indicating the number of test cases. For each test case:

There's a line containing a string  s   (1|s|100)  consisting of lowercase English letters.
 

Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 

Sample Input
  
  
2 annivddfdersewwefary nniversarya
 

Sample Output
  
  
YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5315  5314  5313  5312  5310 





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>

using namespace std;

char str[10001];
struct node
{
    int x;
    char s;
} q[10010];

int main()
{
    int T;
    char a[] = "anniversary";
    scanf("%d",&T);
    while(T--)
    {
        int flag = 0;
        scanf("%s",str);
        int l = strlen(str);
        int ll = strlen(a);
        int num = 0;
        for(int j=0; j<l; j++)
        {
            for(int i=1; i<=ll; i++)
            {
                if(strncmp(str+j,a+num,i) == 0)
                {
                    int num1 = num + i;
                    for(int jj=j+i; jj<l; jj++)
                    {
                        for(int ii=1; ii<=ll-i; ii++)
                        {
                            if(strncmp(str+jj,a+num1,ii) == 0)
                            {
                                int num2 = num1 + ii;
                                for(int jjj=jj+ii; jjj<l; jjj++)
                                {
                                    if(strncmp(str+jjj,a+num2,ll-num2) == 0)
                                    {
                                        printf("YES\n");
                                        flag = 1;
                                        break;
                                    }
                                }
                            }
                            if(flag == 1)
                            {
                                break;
                            }
                        }
                        if(flag == 1)
                        {
                            break;
                        }
                    }
                    if(flag == 1)
                    {
                        break;
                    }
                }
                if(flag == 1)
                {
                    break;
                }
            }
            if(flag == 1)
            {
                break;
            }

        }
        if(flag == 0)
        {
            printf("NO\n");
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值