POJ 3414 Pots(BFS+回溯)

Pots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11705 Accepted: 4956 Special Judge

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

Source

Northeastern Europe 2002, Western Subregion




    题意:输入3个整数n,m,k,前两个整数代表两个杯子的容量,要求用两个杯子通过倒满,倒空,倒入另一个杯子等方法使得两个杯子中的其中一个杯子的水量等于k,并输出步骤。
    思路:题目很简单,就是麻烦。特别是步骤那一部分,需要用到BFS的回溯,通过BFS进行搜索,记录两个杯子的水量,使得后面不得重复。如果搜不到就输出impossible



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>

using namespace std;

int n,m,k;
int ans;
int v[110][110];

struct node
{
    int x;
    int y;
    int z;
    int cnt;
} a[1000010];

void DFS(int kk)
{
    int pt = a[kk].cnt;
    if(pt<=0)
    {
        return ;
    }
    DFS(pt);
    if(a[pt].x == 1)
    {
        if(a[pt].y == 1)
        {
            printf("FILL(1)\n");
        }
        else
        {
            printf("FILL(2)\n");
        }
    }
    else if(a[pt].x == 2)
    {
        if(a[pt].y == 1)
        {
            printf("DROP(1)\n");
        }
        else
        {
            printf("DROP(2)\n");
        }
    }
    else if(a[pt].x == 3)
    {
        if(a[pt].y == 1)
        {
            printf("POUR(1,2)\n");
        }
        else
        {
            printf("POUR(2,1)\n");
        }
    }
}

void BFS()
{
    ans = 1;
    queue<node>q;
    memset(v,0,sizeof(v));
    struct node t,f;
    t.x = 0;
    t.y = 0;
    t.z = 0;
    t.cnt = 0;
    a[0].x = 0;
    a[0].y = 0;
    a[0].cnt = 0;
    q.push(t);
    v[t.x][t.y] = 1;
    while(!q.empty())
    {
        t = q.front();
        q.pop();
        for(int i=1; i<=3; i++)
        {
            for(int j=1; j<=2; j++)
            {
                f.x = t.x;
                f.y = t.y;
                if(i == 1)
                {
                    if(j == 1 && f.x!=n)
                    {
                        f.x = n;
                    }
                    else if(j == 2 && f.y!=m)
                    {
                        f.y = m;
                    }
                }
                else if(i == 2)
                {
                    if(j == 1 && f.x!=0)
                    {
                        f.x = 0;
                    }
                    else if(j == 2 && f.y!=0)
                    {
                        f.y = 0;
                    }
                }
                else if(i == 3)
                {
                    if(j == 1 && (f.x!=0 && f.y!=m))
                    {
                        if(f.x>=m-f.y)
                        {
                            f.x = f.x - m + f.y;
                            f.y = m;
                        }
                        else
                        {
                            f.y = f.y + f.x;
                            f.x = 0;
                        }
                    }
                    else if(j == 2 && (f.y!=0 && f.x!=n))
                    {
                        if(f.y>=n-f.x)
                        {
                            f.y =  f.y - n + f.x;
                            f.x = n;
                        }
                        else
                        {
                            f.x = f.x + f.y;
                            f.y = 0;
                        }
                    }
                }
                if(v[f.x][f.y] == 0)
                {
                    f.cnt = ans;
                    f.z = t.z + 1;
                    a[ans].x = i;
                    a[ans].y = j;
                    a[ans].cnt = t.cnt;
                    q.push(f);
                    v[f.x][f.y] = 1;
                    if(f.x == k || f.y == k)
                    {
                        printf("%d\n",f.z);
                        DFS(ans);
                        if(i == 1)
                        {
                            if(j == 1)
                            {
                                printf("FILL(1)\n");
                            }
                            else
                            {
                                printf("FILL(2)\n");
                            }
                        }
                        else if(i == 2)
                        {
                            if(j == 1)
                            {
                                printf("DROP(1)\n");
                            }
                            else
                            {
                                printf("DROP(2)\n");
                            }
                        }
                        else if(i == 3)
                        {
                            if(j == 1)
                            {
                                printf("POUR(1,2)\n");
                            }
                            else
                            {
                                printf("POUR(2,1)\n");
                            }
                        }
                        return ;
                    }
                    ans++;
                }
            }
        }
    }
    printf("impossible\n");
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        BFS();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值