HDU 5344 MZL's xor(水题)

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 456    Accepted Submission(s): 322


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai + Aj )( 1i,jn )
The xor of an array B is defined as  B1  xor  B2 ...xor  Bn
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n , m , z , l
A1=0 , Ai=(Ai1m+z)   mod   l
1m,z,l5105 , n=5105
 

Output
For every test.print the answer.
 

Sample Input
  
  
2 3 5 5 7 6 8 8 9
 

Sample Output
  
  
14 16
 

Source



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define eps 1e-6

using namespace std;

int n,m,z,l;
int v[500015];
__int64 a[500015];
int b[500015];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d",&n,&m,&z,&l);
        memset(v,0,sizeof(v));
        v[0] = 1;
        a[0] = 1;
        int ph,pi;
        int i;
        int flag = 0;
        m = m%l;
        z = z%l;
        for(i=2;i<=n;i++)
        {
            a[i] = ((a[i-1]*m)+z)%l;
            //printf("a[%d] = %d\n",i,a[i]);
            v[a[i]]++;
        }
        int k = 1;
        for(int i=1;i<=n;i++)
        {
            if(v[a[i]]%2 == 1)
            {
                b[k] = a[i];
                v[a[i]] = 0;
                k++;
            }
        }
        __int64 sum = 0;
        __int64 sum1 = 0;
        for(int i=1;i<k;i++)
        {
            sum = b[i] + b[i];
            sum1^=sum;
        }
        printf("%I64d\n",sum1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值