A Bug's Life
Time Limit: 10000MS | Memory Limit: 65536K | |
Total Submissions: 31306 | Accepted: 10268 |
Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
题意:输入n个bug,bug之间有bug,当前假设异性之间才bug,但是需要验证,给定这些bug对,判定是否满足假设 ,如果男<->女和女<->男,满足条件,如果存在男<->男或者女<->女,则假设不满足
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
const int maxn = 100010;
int bin[maxn],family[maxn];
int n,m;
int findx(int x)
{
int r;
if(bin[x]!=x)
{
r = findx(bin[x]);
family[x] = family[x]^family[bin[x]];
return bin[x] = r;
}
return x;
}
void bing(int x,int y)
{
int fx = findx(x);
int fy = findx(y);
bin[fx] = fy;
family[fx] = ~(family[y]^family[x]);
}
int main()
{
int T;
int kk = 0;
scanf("%d",&T);
while(T--)
{
int flag = 0;
char str[5];
int x,y;
scanf("%d%d",&n,&m);
for(int i=0; i<=n; i++)
{
bin[i] = i;
family[i] = 0;
}
for(int i=0; i<m; i++)
{
scanf("%d%d",&x,&y);
if(findx(x) == findx(y)){
if(family[x]==family[y]){
flag = 1;
}
}else{
bing(x,y);
}
}
printf("Scenario #%d:\n",++kk);
if(flag == 0){
printf("No suspicious bugs found!\n");
}else{
printf("Suspicious bugs found!\n");
}
printf("\n");
}
return 0;
}