HDU 4272 LianLianKan(模拟)

LianLianKan

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3292    Accepted Submission(s): 996


Problem Description
I like playing game with my friend, although sometimes looks pretty naive. Today I invent a new game called LianLianKan. The game is about playing on a number stack.
Now we have a number stack, and we should link and pop the same element pairs from top to bottom. Each time, you can just link the top element with one same-value element. After pop them from stack, all left elements will fall down. Although the game seems to be interesting, it's really naive indeed. 

To prove I am a wisdom among my friend, I add an additional rule to the game: for each top element, it can just link with the same-value element whose distance is less than 6 with it. 
Before the game, I want to check whether I have a solution to pop all elements in the stack.
 

Input
There are multiple test cases.
The first line is an integer N indicating the number of elements in the stack initially. (1 <= N <= 1000)
The next line contains N integer ai indicating the elements from bottom to top. (0 <= ai <= 2,000,000,000)
 

Output
For each test case, output “1” if I can pop all elements; otherwise output “0”.
 

Sample Input
  
  
2 1 1 3 1 1 1 2 1000000 1
 

Sample Output
  
  
1 0 0
 

Source



    题意:给出一个序列,其中距离不超过6的两个相同的数字可以消除掉,现在问把能消除的全部消除之后序列中是不是还有数字,有的话输出0,没有的话输出1

思路:按照题意模拟一遍然后判断是不是为空就可以了




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<stack>
#include<vector>
#include<map>

using namespace std;

int n;
__int64 a[10010];
int v[10010];
__int64 b[10010];

int main() {
    while(scanf("%d",&n)!=EOF) {
        for(int i=1; i<=n; i++) {
            scanf("%I64d",&a[i]);
        }
        memset(v,0,sizeof(v));
        int t = 0;
        int flag;
        for(int i=1; i<=n; i++) {
            int pt = t;
            flag = 0;
            if(v[i] == 1){
				continue;
            }
            for(int k=1; k<=t; k++) {
                if(a[i] == b[k]) {
                    for(int pi=k; pi<t; pi++) {
                        b[pi] = b[pi+1];
                    }
                    t--;
                    flag = 1;
                }
            }
            if(pt == t) {
                int pf = 0;
                for(int j=i+1; j<=i+5 && j<=n; j++) {
                    if(a[i] == a[j]) {
                        v[i] = 1;
                        v[j] = 1;
                        pf = 1;
                        break;
                    }
                }
                if(pf == 0) {
                    b[++t] = a[i];
                }
            }
        }
        if(t == 0) {
            printf("1\n");
        } else {
            printf("0\n");
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值