Luogu P3120 [USACO15FEB]牛跳房子(金)Cow Hopscotch (Gold)

3 篇文章 0 订阅
1 篇文章 0 订阅

Cow Hopscotch

题目描述
Just like humans enjoy playing the game of Hopscotch, Farmer John;s cows have invented a variant of the game for themselves to play. Being played by clumsy animals weighing nearly a ton, Cow Hopscotch almost always ends in disaster, but this has surprisingly not deterred the cows from attempting to play nearly every afternoon.
The game is played on an R by C grid (2 <= R <= 750, 2 <= C <= 750), where each square is labeled with an integer in the range 1..K (1 <= K <= R*C). Cows start in the top-left square and move to the bottom-right square by a sequence of jumps, where a jump is valid if and only if
1) You are jumping to a square labeled with a different integer than your current square,
2) The square that you are jumping to is at least one row below the current square that you are on, and
3) The square that you are jumping to is at least one column to the right of the current square that you are on.
Please help the cows compute the number of different possible sequences of valid jumps that will take them from the top-left square to the bottom-right square.
就像人类喜欢跳格子游戏一样,FJ的奶牛们发明了一种新的跳格子游戏。虽然这种接近一吨的笨拙的动物玩跳格子游戏几乎总是不愉快地结束,但是这并没有阻止奶牛们在每天下午参加跳格子游戏
游戏在一个R*C的网格上进行,每个格子有一个取值在1-k之间的整数标号,奶牛开始在左上角的格子,目的是通过若干次跳跃后到达右下角的格子,当且仅当格子A和格子B满足如下条件时能从格子A跳到格子B:
1.B格子在A格子的严格右方(B的列号严格大于A的列号)
2.B格子在A格子的严格下方(B的行号严格大于A的行号)
3.B格子的标号和A格子的标号不同
请你帮助奶牛计算出从左上角的格子到右下角的格子一共有多少种不同的方案
输入输出格式
输入格式:
The first line contains the integers R, C, and K.
The next R lines will each contain C integers, each in the range 1..K.
输出格式:
Output the number of different ways one can jump from the top-left square to the bottom-right square, mod 1000000007.
输入输出样例
输入样例#1:
4 4 4
1 1 1 1
1 3 2 1
1 2 4 1
1 1 1 1
输出样例#1:
5
这是一道典型的记忆化搜索题。
f[x][y]表示以x,y为右下角的方案数。

code

#include <cstdio>
#define mod 1000000007
using namespace std;
int n,m,k,a[751][751],f[751][751];
int DP(int x,int y){
    if(f[x][y])return f[x][y];
        for(int i=1;i<x;i++)
            for(int j=1;j<y;j++)
                if(a[i][j]!=a[x][y])f[x][y]+=DP(i,j),f[x][y]%=mod;
    return f[x][y];          
}
int main(){
    scanf("%d %d %d\n",&n,&m,&k);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)scanf("%d",&a[i][j]);
    f[1][1]=1;
    printf("%d",DP(n,m));
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值