5-53 Consecutive Factors   (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<<N<231<2^31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

解析:题意是要找N的一个最大(因子个数最多)最小(因子个数相同,第一个因子最小的)连续因子序列。也就是说,先要找到因子个数最多的连续因子序列,如果有多个这样的连续因子序列,则选择第一个因子最小的。最后,第一行输出连续因子的最大因子个数,第二行输出那个最小的连续因子序列。

注意:质数的连续因子序列是它本身。

#include <stdio.h>
#include <math.h>
int main () {
	int N;  //devC++中int和long都是32位,4个字节,表示范围 -2^31 ~ 2^31 - 1 
	int k, start, maxNum, firstFactor;
	scanf("%d", &N);
	k = sqrt(N); //减少循环次数 
	maxNum = 1;  //连续因子个数至少有一个 
	firstFactor = N; //假定N是质数,firstFactor一次都不会更新 
	for ( int i = 2; i <= k; i++ ) { 
		int tmp = N;
		start = i;
		while ( tmp % start == 0 ) { //从start开始寻找连续因子 
			tmp /= start;
			start++;
		}
		if ( start - i > maxNum ) { //如果因子个数大于maxNum 
			firstFactor = i;	//更新第一个因子 
			maxNum = start - i;	//更新最大连续因子个数 
		}
		else if ( start - i == maxNum && i < firstFactor ) { //如果因子个数相等,则选择第一个因子小的 
			firstFactor = i;
		}
	}
	printf("%d\n", maxNum);
	//不能写成for ( int i = firstFactor; i < firstFactor + maxNum; i++ )
	//因为当firstFactor是2147483647时, firstFactor + maxNum将超出int范围,比较会出错(具体是如何比较的?) 
	for ( int i = 0; i < maxNum; i++ ) {
		if ( i != 0 )
			printf("*");
		printf("%d", firstFactor + i);
	}
	return 0;	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值