01-复杂度2 Maximum Subsequence Sum   (25分)

Given a sequence of KK integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains KK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices ii and jj (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


思路:

1、在线处理子序列的最大和

2、在线处理的特点是新序列可能会代替旧序列,也可能不会。(新序列是指第一个元素是新的,旧序列指第一个元素还是上一次的第一个元素)

3、每次一个新序列开始时,就记下这个序列的第一个元素(它是可能的最大子列和的第一个元素)

4、每次旧序列的最大值要被一个序列代替时(最后一个元素必须更新),检查一下它是不是新序列,是的话,就把第一个元素也更新(旧序列被新序列代替)


注意点:

1、题目中有测试点是全负数的,所以要有个AllNegative的标记来分辨

2、还有个测试点是序列由0和负数组成的,MaxSum设为-1,就能把第一个0(这是个只有一个0的序列)记录下来。输出 0 0 0


#include <stdio.h>
#include <stdlib.h>
int MayBeStart = 0;	//可能的最大子列和的第一个元素
int start, end, AllNegative = 1, Update = 1;
int MaxSubsequenceSum(int a[], int N){
	int MaxSum = -1, ThisSum = 0;	//MaxSum设为-1,可以解决只有负数和零的情况
	for(int i = 0; i < N; i++){
		ThisSum += a[i];
		if ( ThisSum > MaxSum ) {
			if ( Update ) { //这是个新的序列,所以要更新第一个元素
				start = MayBeStart;
				Update = 0; //新的序列变为旧序列,旧序列不需要更新第一个元素,但是要更新最后一个
			}
			MaxSum = ThisSum;
			end = i;		//每次更换最大值时,更新子序列最后一个元素下标
			AllNegative = 0;	//表明不是全负数
		}
		else if ( ThisSum < 0 ) {
			ThisSum = 0;
			MayBeStart = i + 1;	//记录可能的第一个元素下标
			Update = 1;	//新的序列又开始了
		}
	}
	return MaxSum;
}
int main(){
	int N, a[10005], sum;
	scanf("%d", &N);
	for(int i = 0; i < N; i++)
		scanf("%d", &a[i]);
	sum = MaxSubsequenceSum(a, N);
	if ( !AllNegative ) { //如果不是全负数
		printf("%d %d %d", sum, a[start], a[end]);
		//printf("%d %d %d", MaxSubsequenceSum(a, N), a[start], a[end]);	//函数不会改变start和end的值  为什么???
		//printf("%d %d", start, end); //这里的start和end改变了,说明上一步三个输出是同时进行的(可能)
	}
	else
		printf("0 %d %d", a[0], a[N - 1]);
	system("pause");
	return 0;
}



题目描述 给定K个整数组成的序列{ N1, N2, ..., NK },“连续子列”被定义为{ Ni, Ni+1, ..., Nj },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{-2, 11, -4, 13, -5, -2},其最大子列和为20,对应子列为{ 11, -4, 13 }。 现在你应该给出一个算法,计算给定整数序列的最大子列和。 输入格式 输入第1行给出正整数K(K≤10000),第2行给出K个整数,其间以空格隔。 输出格式 在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出。 输入样例 6 -2 11 -4 13 -5 -2 输出样例 20 算法1 (暴力枚举) $O(n^2)$ 暴力枚举所有的子序列,计算它们的和,最后找到最大的和即可。 时间复杂度 枚举所有子序列,时间复杂度为$O(n^2)$。 C++ 代码 算法2 (治) $O(nlogn)$ 将序列成左右两部,最大子序列和可能在左边、右边或者跨越中间。如果最大子序列和在左边或者右边,那么可以递归求解;如果最大子序列和跨越中间,那么可以别求出左边的最大后缀和和右边的最大前缀和,然后将它们相加即可。 时间复杂度 每次递归都会将序列成两部,时间复杂度为$O(logn)$,而每次计算跨越中间的最大子序列和的时间复杂度为$O(n)$,所以总的时间复杂度为$O(nlogn)$。 C++ 代码 算法3 (动态规划) $O(n)$ 用dp[i]表示以i结尾的最大子序列和,那么dp[i]的值可以由dp[i-1]和a[i]计算得到。如果dp[i-1]是负数,那么dp[i]就是a[i];否则dp[i]就是dp[i-1]+a[i]。最后找到dp数组中的最大值即可。 时间复杂度 只需要遍历一遍数组,时间复杂度为$O(n)$。 C++ 代码
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值