02-线性结构3 Reversing Linked List   (25分)

Given a constant KK and a singly linked list LL, you are supposed to reverse the links of every KK elements on LL. For example, given LL being 1→2→3→4→5→6, if K=3K = 3, then you must output 3→2→1→6→5→4; if K=4K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive NN (≤10510^5) which is the total number of nodes, and a positive KK (N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then NN lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

思路:

1、用结构数组模拟链表

2、题意是满足K个结点的一段链表就要逆转,而不满K个结点的不需要逆转(比如有10个结点的链表,K为4,那么分为两部分:0123,4567需要逆转,89只有2个不逆转)

3、用三个指针New,Old,Tmp来完成一段(K个结点)的链表的逆转(具体看mooc上的思路);对应Reverse函数

4、mooc上只给了一段链表的逆转,而没有给整个的,所以需要自己写整个链表的逆转;对应ReversingLinkedList函数

#include <stdio.h>
#include <stdlib.h>
#define MaxSize 100000
typedef int Ptr;
//结构数组模拟链表
struct node{
	int key;
	Ptr next;
}list[MaxSize];

//逆转某一段含K个结点的链表
Ptr Reverse ( Ptr head, int K ) {
	Ptr New, Old, Tmp; //New指向逆转链表表头,Old指向未逆转表头,Tmp记录Old后一个结点
	int cnt = 1;
	New = head;
	Old = list[New].next;
	while ( cnt < K ) {
		Tmp = list[Old].next; //记录Old下一个结点,防止逆转指针后丢失
		list[Old].next = New; //逆转指针
		New = Old; Old = Tmp; //New,Old向后转移一个
		cnt++;
	}
	list[head].next = Old; //原来的第一个结点逆转后变为最后一个结点,并连接剩下未逆转的元素
	return New;
}

//判断是否需要逆转
int NeedReverse ( Ptr head , int K) {
	int i;
	for( i = 1; list[head].next != -1; head = list[head].next ) {
		i++;
		if ( i == K ) return 1; //还有K个或以上结点,需要逆转
	}
	return 0; //不足K个结点,不需要逆转
}

//逆转整个链表
Ptr ReversingLinkedList( Ptr head , int K ) {
	Ptr UnreversedHead = head;	//未逆转的链表的第一个结点
	Ptr ListHead; //整个表的第一个结点
	Ptr TempTail; //临时表尾,用来连接下一段逆转的链表

	if ( NeedReverse( UnreversedHead, K ) ) { //第一次先判断是否需要逆转
		ListHead = Reverse( UnreversedHead, K ); //记住逆转后的整个链表的第一个结点
		TempTail = UnreversedHead; //记录此逆转链表的表尾
		UnreversedHead = list[TempTail].next; //记录未逆转链表的表头
	}
	else //链表结点个数小于K,无需逆转
		return head;

	while ( NeedReverse( UnreversedHead, K ) ) {
		list[TempTail].next = Reverse( UnreversedHead, K ); //上一个逆转链表的表尾与这个逆转链表的表头连接
		TempTail = UnreversedHead;
		UnreversedHead = list[TempTail].next;
	}
	return ListHead;
}

//输出链表
void PrintLinkedList ( Ptr head ) {
	Ptr temp = head;
	for(; list[temp].next !=  -1;  temp = list[temp].next)
		printf("%05d %d %05d\n", temp, list[temp].key, list[temp].next);
	printf("%05d %d %d\n", temp, list[temp].key, list[temp].next);
}

int main(){
	Ptr ad, head;
	int N, K;
	scanf("%d %d %d", &head, &N, &K);
	for(int i = 0; i < N; i++){
		scanf("%d", &ad);
		scanf("%d %d", &list[ad].key, &list[ad].next);
	}
	PrintLinkedList( ReversingLinkedList( head, K ) );
	system("pause");
	return 0;
}


题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值