UVA 10110 Light, more light

Light,more light

The Problem

There is man named "mabu" for switching on-off light in our University.He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption(or may be he is mad or something else) he does a peculiar thing. If ina corridor there is `n' bulbs, he walks along the corridor back and forth`n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position.A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less thenor equals 2^32-1. A zero indicates the end of input. You should not processthis input.

The Output

Output " yes" if the light is on otherwise " no" , in a single line.

SampleInput

3
6241
8191
0

SampleOutput

no
yes
no

Sadi Khan
Suman Mahbub
01-04-2001





题目意思就是有一个走廊,走廊上有很多灯。。有一个人在那开关。。

如过有n盏灯,他就走n躺,回来的时候不动开关。。

走第一趟,就动可以被一整除的开关,

走第二趟就动能被二整除的开关,第2,4,6,8.。。。盏。。

问n趟走完,最后一盏灯是开是关。。。


如果从1开始遍历,看看能被整出的数有多少个,偶数个就是关,奇数个就是开的话,,是一定会超时的。。。


所以找到了一个规律,,如果灯的数量是可以被开方的,,像1,4,9,16最后就是开的,yes,否则就是no。。


AC代码:


#include<stdio.h>
#include<cmath>
int main () {

	double num;
	while (scanf("%lf",&num)) {
		if (num == 0)
			break;
		if ( (int)sqrt(num) == sqrt(num)  )
			printf("yes\n");
		else 
			printf("no\n");
	}



	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值