UVA10112 Myacm Triangles

Problem B: Myacm Triangles

Source file:triangle.{c, cpp, java, pas}
Input file:triangle.in
Output file:triangle.out

There has been considerable archeological work on the ancient Myacm culture. Many artifacts have been found in what have been called power fields: a fairly small area, less than 100 meters square where there are from four to fifteen tall monuments with crystals on top. Such an area is mapped out above. Most of the artifacts discovered have come from inside a triangular area between just three of the monuments, now called the power triangle. After considerable analysis archeologists agree how this triangle is selected from all the triangles with three monuments as vertices: it is the triangle with the largest possible area that does not contain any other monuments inside the triangle or on an edge of the triangle. Each field contains only one such triangle.

Archeological teams are continuing to find more power fields. They would like to automate the task of locating the power triangles in power fields. Write a program that takes the positions of the monuments in any number of power fields as input and determines the power triangle for each power field.

A useful formula: the area of a triangle with vertices (x1, y1), (x2, y2), and (x3, y3) is the absolute value of

0.5 × [( y 3 - y 1)( x 2 - x 1) - ( y 2 - y 1)( x 3 - x 1)].

For each power field there are several lines of data. The first line is the number of monuments: at least 4, and at most 15. For each monument there is a data line that starts with a one character label for the monument and is followed by the coordinates of the monument, which are nonnegative integers less than 100. The first label is A, and the next is B, and so on.

There is at least one such power field described. The end of input is indicated by a 0 for the number of monuments. The first sample data below corresponds to the diagram in the problem.

For each power field there is one line of output. It contains the three labels of the vertices of the power triangle, listed in increasing alphabetical order, with no spaces.

Example input:

6
A 1 0
B 4 0
C 0 3
D 1 3
E 4 4
F 0 6
4
A 0 0
B 1 0
C 99 0
D 99 99
0

Example output:

          BEF

          BCD



题目的意思就是有超过15个的点。。找到组成最大的三角形,且内部不包含其他点  的三个点。。。

思路就是暴力求解,枚举所有三角形,找出面积最大且里面不包含点的;

不包含点的判断的可以这样做:如果一个点是在内部,则这个点和其他任意两点组成的三个三角形面积等于原来那个三角形面积。

三角形面积求法,题目上给出了。。


AC代码:


#include<stdio.h>
#include<cmath>

struct point {
	char ch;
	double x;
	double y;
};
double area (double x1,double x2,double x3,double y1,double y2,double y3) {

	return  fabs( 0.5 * ( (y3 - y1) * (x2 - x1) - (y2 - y1) * (x3 - x1)) );

}
int main () {
	int t;
	double max;
	double s;
	char q,w,e;
	int flag;
	point p[20];
	while(scanf("%d",&t)) {
		max = 0;
		if (t == 0)
			break;
		for (int i = 0; i < t ;i++) {
			getchar();
			scanf("%c%lf%lf",&p[i].ch,&p[i].x,&p[i].y);
		}
		for (int i = 0;i < t;i++)
			for(int j = i + 1;j < t;j++) 
				for(int k = j + 1;k < t ; k++) {
					flag = 1;
					s = area(p[i].x,p[j].x,p[k].x,p[i].y,p[j].y,p[k].y);
					for (int l = 0;l < t ;l ++) {
							if (l == i||l == j || l == k)
								continue;
							if(s + 0.000000001 > area(p[i].x , p[j].x ,p[l].x ,p[i].y ,p[j].y, p[l].y) + area(p[l].x , p[j].x ,p[k].x ,p[l].y ,p[j].y, p[k].y) + area(p[i].x , p[l].x ,p[k].x ,p[i].y ,p[l].y, p[k].y)  && s - 0.00000001 < area(p[i].x , p[j].x ,p[l].x ,p[i].y ,p[j].y, p[l].y) + area(p[l].x , p[j].x ,p[k].x ,p[l].y ,p[j].y, p[k].y) + area(p[i].x , p[l].x ,p[k].x ,p[i].y ,p[l].y, p[k].y) )
							flag = 0;
					}
					if (flag == 1 && s >= max ) {	
						max = s;
						q = p[i].ch;
						w = p[j].ch;
						e = p[k].ch;

					}




				}

		printf("%c%c%c\n",q,w,e);

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值