ZOJ--1006:Do the Untwist

Do the Untwist

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Cryptography deals with methods of secret communication that transform a message (theplaintext) into a disguised form (the ciphertext) so that no one seeing the ciphertext will be able to figure out the plaintext except the intended recipient. Transforming the plaintext to the ciphertext isencryption; transforming the ciphertext to the plaintext isdecryption. Twisting is a simple encryption method that requires that the sender and recipient both agree on a secret keyk, which is a positive integer.

The twisting method uses four arrays: plaintext and ciphertext are arrays of characters, andplaincode and ciphercode are arrays of integers. All arrays are of lengthn, where n is the length of the message to be encrypted. Arrays are origin zero, so the elements are numbered from 0 ton - 1. For this problem all messages will contain only lowercase letters, the period, and the underscore (representing a space).

The message to be encrypted is stored in plaintext. Given a key k, the encryption method works as follows. First convert the letters inplaintext to integer codes in plaincode according to the following rule: '_' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26, and '.' = 27. Next, convert each code inplaincode to an encrypted code in ciphercode according to the following formula: for alli from 0 to n - 1,

ciphercode[ i] = ( plaincode[ ki mod n] - i) mod 28.

(Here x mod y is the positive remainder when x is divided byy. For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. You can use the C '%' operator or Pascal 'mod' operator to compute this as long as you addy if the result is negative.) Finally, convert the codes in ciphercode back to letters inciphertext according to the rule listed above. The final twisted message is inciphertext. Twisting the message cat using the key 5 yields the following:

Array012
plaintext'c''a''t'
plaincode3120
ciphercode31927
ciphertext'c''s''.'

Your task is to write a program that can untwist messages, i.e., convert the ciphertext back to the original plaintext given the keyk. For example, given the key 5 and ciphertext 'cs.', your program must output the plaintext 'cat'.

The input file contains one or more test cases, followed by a line containing only the number 0 that signals the end of the file. Each test case is on a line by itself and consists of the keyk, a space, and then a twisted message containing at least one and at most 70 characters. The keyk will be a positive integer not greater than 300. For each test case, output the untwisted message on a line by itself.

Note: you can assume that untwisting a message always yields a unique result. (For those of you with some knowledge of basic number theory or abstract algebra, this will be the case provided that the greatest common divisor of the keyk and length n is 1, which it will be for all test cases.)

Example input:

5 cs.
101 thqqxw.lui.qswer
3 b_ylxmhzjsys.virpbkr
0

Example output:

cat
this_is_a_secret
beware._dogs_barking



思路:

    这里只要搞懂ciphercode[i] = (plaincode[ki modn- i) mod 28.就ok了

    又该公式可得plaincode[ki modn]=(ciphercode[i] +i) mod 28    x=k*i mod n

import java.util.Scanner;

public class Do_the_Untwist {
	static int key,n;
	static String str;
	static char plain[];
	public static void main(String[] args) {
		Scanner s=new Scanner(System.in);
		while((key=s.nextInt())!=0){
			str=s.next();
			n=str.length();
			plain=new char[n];
			for(int i=0;i<n;i++){
				int x=(key*i)%n;
				plain[x]=con2((con1(str.charAt(i))+i)%28);
			}
			for(char i:plain){
				System.out.print(i);
			}
			System.out.println();
		}
	}
	public static int con1(char a){
		if(a=='_')
			return 0;
		if(a=='.')
			return 27;
		return a-96;
	}
	public static char con2(int a){
		if(a==0)
			return '_';
		if(a==27)
			return '.';
		return (char) (a+96);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值