Wormholes

Wormholes

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 6
Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

 

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.
 

Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
 

Sample Input
  
  
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
 

Sample Output
  
  
NO YES
 

Source
PKU
 
/***
题目大意:问john利用虫洞的时光旅行能否在回到出发之前的某一地点看到他本人.

思路:   bellman_ford算法(可用SPFA算法)
        再寻找负权环
        若有,则john可以通过这个环达成目标;否则,目标无法实现.
***/
#include <iostream>
#include <cstring>

using namespace std;

#define maxn 505
#define maxm 25005

int dis[1001];  //源点到各点权值(min)
int N,M,W;

struct NODE
{
    int f;  //from
    int t;  //to
    int w;
} edge[maxm];

void read_edge()
{
    cin>>N>>M>>W;
    for(int i=0; i<M; i++)
    {
        cin>>edge[i].f>>edge[i].t>>edge[i].w;   //前M条路是双向的
        edge[M+i].f=edge[i].t;
        edge[M+i].t=edge[i].f;
        edge[M+i].w=edge[i].w;
    }

    for(int i=2*M; i<2*M+W; i++)
    {
        cin>>edge[i].f>>edge[i].t>>edge[i].w;  //后W条路是单向的,但是却是负权边
        edge[i].w*=-1;
    }
}

void bellman_ford()             //bellman_ford算法
{
    memset(dis,-1,sizeof(dis));
    bool flag=0;
    int i,j;

    for(i=0; i<N-1; i++)
    {
        flag=0;
        for(j=0; j<2*M+W; j++)
            if(dis[edge[j].t]>dis[edge[j].f]+edge[j].w)
            {
                dis[edge[j].t]=dis[edge[j].f]+edge[j].w;
                flag=1;
            }
        if(!flag)
            break;
    }
}

bool search_NC()              //寻找负权环
{
    int i;
    for(i=0; i<2*M+W; i++)
    {
        if(dis[edge[i].t]>dis[edge[i].f]+edge[i].w)     //负权环出现
            return true;
    }
    return false;
}

int main()
{
    int icas;
    cin>>icas;
    while(icas--)
    {
        read_edge();
        bellman_ford();
        if(search_NC())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值