Wormholes
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 36782 | Accepted: 13467 |
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
嗯,题目大意就是说,n个农场,m条双向路,w条单向虫洞,虫洞会把人送到终点并且时间倒流。问人能否从1出发回来再看到他自己。也就是说有没有负环,若有则可以,若无则不可以
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 1010
#define maxm 6000+60
#define inf 0x3f3f3f3f
using namespace std;
int n,m,w,cnt,mark,head[maxn];
struct node
{
int from,to,val,next;
};
node edge[maxm];
void initialize()
{
cnt=0;
mark=0;
memset(head,-1,sizeof(head));
}
void add(int a,int b,int c)
{
edge[cnt].from=a;
edge[cnt].to=b;
edge[cnt].val=c;
edge[cnt].next=head[a];
head[a]=cnt++;
}
void spfa(int s)
{
int flag=0;
queue<int>q;
int vis[maxn],dis[maxn],used[maxn];
memset(dis,inf,sizeof(dis));
memset(vis,0,sizeof(vis));
memset(used,0,sizeof(used));
vis[s]=1;
dis[s]=0;
used[s]++;
q.push(s);
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(dis[v]>dis[u]+edge[i].val)
{
dis[v]=dis[u]+edge[i].val;
if(!vis[v])
{
vis[v]=1;
used[v]++;
if(used[v]>n)
{
flag=1;
break;
}
q.push(v);
}
}
}
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
int main()
{
int t,a,b,c;
scanf("%d",&t);
while(t--)
{
initialize();
scanf("%d%d%d",&n,&m,&w);
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
while(w--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,-c);
}
spfa(1);
}
return 0;
}