Stars

Stars

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 
/**树状数组**/
#include <iostream>
#include <cstdio>

using namespace std;
#define lowbit(x) (x)&(-x)
#define maxn 15000<<2

int sum[maxn+10]={0};
int level[maxn+10]={0};
int n=32010;/**树状数组:区间大小必须要已知,未知的要进行估算,
因为元素更新是从下到上的,如果没有确定的上界,会导致某些靠后的区间无法修改**/

void change(int x)//add = 1
{
    while(x<=n)
    {
        sum[x]=sum[x]+1;
        x+=lowbit(x);/**低位技术**/
    }
}

int Query(int x)/**1~x,查询前缀和**/
{
    int ans=0;
    while(x>0)
    {
        ans+=sum[x];
        x-=lowbit(x);
    }
    return ans;
}

int main()
{
    int N;
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        x++;/**原题给的坐标中会出现 0,而树状数组是从1开始的!所以,所有x+1,就可使所有数据不从0开始**/
        level[Query(x)]++;
        change(x);

    }
    for(int i=0;i<N;i++)
        printf("%d\n",level[i]);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Gitee 是一个国内知名的代码托管平台,类似于国外的 GitHub,用户可以在上面创建仓库并进行代码托管。获取仓库的 stars 是评估该仓库受欢迎程度的一种方式。 要获取一个仓库的 stars 数量,首先需要登录 Gitee 平台,并找到该仓库的主页。在仓库主页的右上方有一个 "Star" 的按钮,点击该按钮即可为该仓库增加一个 star。同时,在该按钮的旁边还会显示当前该仓库的 stars 数量,用于了解该仓库的受欢迎程度。 除了手动点击按钮增加 stars,Gitee 还提供了 API 接口,可以通过编程的方式获取 stars 数量。使用 API 获取 stars 时,需要先获取该仓库的 ID 或者完整地址,并使用合法的 API 调用权限。然后通过 API 请求,可以获取到该仓库的 stars 数量,以便在其他应用程序中使用。 获取仓库的 stars 数量对于开发者来说具有重要意义,因为 stars 数量越多,代表有更多的人对该仓库感兴趣,并且可能意味着该仓库的代码质量较高。对于项目的维护者来说,高 stars 数量也意味着更多的社区支持和用户贡献,这将对项目的发展和推广都起到积极的作用。 总结来说,想要获取 Gitee 上一个仓库的 stars 数量,可以手动点击仓库主页上的 "Star" 按钮进行查看,也可以使用 API 来获取并在其他应用程序中使用。同时,高 stars 数量也是一个代码仓库受欢迎程度的重要指标。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值