Stars
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 53881 | Accepted: 23182 |
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5 1 1 5 1 7 1 3 3 5 5
Sample Output
1 2 1 1 0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
解析:
因为保证了 Y 坐标是单调递增的,所以我们只用算出读入的每个点之前有多少个点横坐标小于等于它就行了,用树状数组能快速求解。
代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cctype>
using namespace std;
const int Max=15010;
int n,m;
int ans[Max],sum[32010];
inline int get_int()
{
int x=0,f=1;
char c;
for(c=getchar();(!isdigit(c))&&(c!='-');c=getchar());
if(c=='-') {f=-1;c=getchar();}
for(;isdigit(c);c=getchar()) x=(x<<3)+(x<<1)+c-'0';
return x*f;
}
inline int lowbit(int x){return x&-x;}
inline void add(int pos,int x){for(;pos<=32001;pos+=lowbit(pos)) sum[pos]+=x;}
inline int Q(int pos)
{
int ans=0;
for(;pos;pos-=lowbit(pos)) ans+=sum[pos];
return ans;
}
inline void print(int x)
{
if(x > 9) print(x/10);
putchar(x % 10 + '0');
}
int main()
{
n=get_int();
for(int i=1;i<=n;i++)
{
int x=get_int()+1,y=get_int();
ans[Q(x)]++;
add(x,1);
}
for(int i=0;i<n;i++) print(ans[i]),putchar('\n');
return 0;
}