Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 27403 Accepted: 11468

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

/**
题目的意思就是求字符串中最大重复子串,即a^n=s求a最大时n的值。

用kmp的next数组来求解,next数组是用来求最大前缀和后缀子串的。

则求出s的值,即s的最长前缀子串和后缀子串相等next[len]的值。

If len%(len-next[len])==0 则len/(len-next[len])就是重复子串的个数,而最大前缀的补就为a。

原因如下

1

2

3

4

5

6

7 len-next[len]
因为len%(len-next[len])==0所以可以假设将s等分为7个则7和6就相等。而1-6和2-7相等6(2-7)和5(1-6)就相等,
即5和7就相等,依次类推就都相等了……
**/
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 1001000

char s[maxn];
int len, next[maxn];

void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}

int main()
{
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='.')
            break;
        len=strlen(s);
        get_next();
        int ans=1;
        if(len%(len-next[len])==0)       //整个长度len能分解成x个这种串
            ans=len/(len-next[len]);
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值