1022. Digital Library (30)

1022. Digital Library (30)

时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

31111111The Testing BookYue Chentest code debug sort keywordsZUCS Print20113333333Another Testing BookYue Chentest code sort keywordsZUCS Print220122222222The Testing BookCYLLkeywords debug bookZUCS Print2201161: The Testing Book2: Yue Chen3: keywords4: ZUCS Print5: 20113: blablabla

Sample Output:

1: The Testing Book111111122222222: Yue Chen111111133333333: keywords1111111222222233333334: ZUCS Print11111115: 2011111111122222223: blablablaNot Found


#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
typedef int book;
int ID[10001];
map<string,vector<book> > mf;//核心数据结构,一个关键词对应一个book指针数组 
void FindAnswer(string s){
 if(mf.find(s)!=mf.end()){ 
 sort(mf[s].begin(),mf[s].end());//我选择最后排序 
 for(int i=0;i!=mf[s].size();i++)
  printf("%07d\n",mf[s][i]);
 }
 else
 cout<<"Not Found"<<endl;
}
void BuildMap(string s,int i){
 vector<book> empty;
 if(mf.find(s)==mf.end())
  mf.insert(pair<string,vector<book> >(s,empty)); 
 mf[s].push_back(ID[i]);
}
int main()
{
 int N,i,j,M;
 string t,search;
 cin>>N;
 for(i=0;i<N;i++){//输入并建立哈希表 
  cin>>ID[i];
  cin.get();
  for(j=0;j<5;j++){
   char c=' ';
   string s;
   if(j!=2){//keyword部分需要单独考虑,其他的部分其实都是一样的 
    getline(cin,s);
    BuildMap(s,i);
   }
   else{
    while(c!='\n'){
     c=cin.get();
    if(c!='\n'&&c!=' ')
     s+=c;
    else if(c==' '){
     BuildMap(s,i);
     s.clear(); 
     }
    }
    BuildMap(s,i);
   }
  }
 }
 cin>>M;
 while(M--){
  cin>>t;
  cin.get();//去除上一个cin留下的回车符号 
  cout<<t<<" ";
  getline(cin,search);
  cout<<search<<endl;
  FindAnswer(search);
  search.clear();
 }
} 


ACM Digital Library(ACM数字图书馆)是全球历史最悠久和最大的计算机教育、科研机构。它收录了美国计算机协会的各种电子期刊、会议录、快报等文献的全文信息,并提供出版物信息。此外,ACM Digital Library还提供了其他3000多家出版机构的计算机文献的文摘索引信息(The Guide)。ACM致力于发展信息技术教育、科研和应用,其出版物和会议记录被全球计算机领域的专业人士视为最具权威和前瞻性的领导者。ACM Digital Library广泛收录了多种ACM电子出版物,包括15年的期刊和杂志、ACM9年的会议记录以及超过25万页的全文资料。此外,你可以在The Guide to Computing Literature中查找计算机领域重要文献的书目信息。\[2\]\[3\] #### 引用[.reference_title] - *1* [如何免费下载ACM数字图书馆文献](https://blog.csdn.net/weixin_46136127/article/details/113838644)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [ACM Digital Library访问及完整联动Zotero](https://blog.csdn.net/weixin_45884316/article/details/127511739)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *3* [ACM数据库的检索应用](https://blog.csdn.net/smart819819/article/details/8201844)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值