PAT (Advanced Level) Practice 1005 Spell It Right (20)(20 分)

1005 Spell It Right (20)(20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题解1:

由于数据范围很大,考虑以字符串形式读入。

计算好各位数和之后,如果以数字格式输出,则必须要求和的位数,然后从高位到低位依次计算输出。

将和从数字格式转换成字符串,直接输出,能够避免繁琐的计算。

源代码1:

#include <iostream>
using namespace std;
int main()
{
	string tab[10] = { "zero","one","two","three","four","five","six","seven","eight","nine"};
	string s;
	int len,i,sum=0;
	cin >> s;
	len = s.length();
	for (i = 0; i < len; i++)
		sum += s[i] - '0';
	s = to_string(sum);
	len = s.length();
	for (i = 0; i < len; i++)
	{
		cout << tab[s[i]-'0'];
		if (i != len - 1) cout << " ";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值