PAT (Advanced Level) Practice 1004 Counting Leaves (30 分)

  • 编程题

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:给出节点总数和非叶节点总数,求每一层的叶节点个数。

题解1:

思路:

每个节点用一个struct node记录,node中使用vector<int>child记录它的子节点。(这题建树比较简单)

深度优先搜索DFS,从根节点01开始,记录每个节点的层数,遇到叶节点后,该层叶节点总数加1,同时记录最大层数。

最后输出所有层数的叶节点个数。

源代码1:

#include<iostream>
#include<stdlib.h>
#include<vector>
using namespace std;
int n, m, i, j, k, temp,maxlevel=0;
int level[100] = { 0 };
struct node
{
	vector<int>child;
};
vector<node>v;
void dfs(int r, int step)
{
	int i;
	if (v[r].child.size()==0)
	{
		level[step]++;
		if (step > maxlevel)maxlevel = step;
		return;
	}
	for (i = 0; i < v[r].child.size(); i++)
	{
		dfs(v[r].child[i], step + 1);
	}
	return;
}
int main()
{
	scanf("%d %d", &n, &m);
	v.resize(n + 1);
	for (i = 1; i <= m; i++)
	{
		scanf("%d %d", &temp,&k);
		v[temp].child.resize(k);
		for (j = 0; j < k; j++)
			scanf("%d", &v[temp].child[j]);	
	}
	dfs(01, 0);
	for (i = 0; i <= maxlevel; i++)
		if (i == 0)printf("%d", level[i]);
		else printf(" %d", level[i]);
	system("pause");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值