题目1042:Coincidence(2008年上海交通大学计算机研究生机试真题)

46 篇文章 0 订阅
46 篇文章 0 订阅
题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1399

解决:748

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2
import java.util.Scanner;
 
public class Main{
 
    static int dp[][] = new int [101][101];
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
         
        while( scanner.hasNext() ){
            String s1 = scanner.next();
            String s2 = scanner.next();
            int l1 = s1.length();
            int l2 = s2.length();
             
            char charOfs1[] = s1.toCharArray();
            char charOfs2[] = s2.toCharArray();
             
            for (int i = 0; i <= l1; i++) {
                dp[i][0] = 0;
            }
             
            for (int i = 0; i <= l2; i++) {
                dp[0][i] = 0;
            }
             
            for (int i = 1; i <= l1; i++) {
                for (int j = 1; j <= l2; j++) {
                    if(charOfs1[i-1] != charOfs2[j-1]){
                        dp[i][j] = max(dp[i][j-1],dp[i-1][j]);
                         
                    }
                    else{
                        dp[i][j] = dp[i-1][j-1] +1;
                    }
                     
                }
            }
            System.out.println(dp[l1][l2]);
        }
    }
    private static int max(int a, int b) {
        return a>b?a:b;
    }
 
}
 
/**************************************************************
    Problem: 1042
    User: yihukurama
    Language: Java
    Result: Accepted
    Time:80 ms
    Memory:15456 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值