HDU 1541 Stars

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3277    Accepted Submission(s): 1280


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

Source
 

Recommend
LL

题意给你一张star maps,每个star有自己的level,level 等于star左下角(即横坐标和纵坐标都比star小的)star的个数(包含横坐标或者纵坐标相等的star),
             分别输出level为0~N-1的star数目,每个一行。 
 

#include<stdio.h>
#include<string.h>
#define N 50000
int c[N];
int ans[N];
int n;
int lowbit(int x)
{
	return x & (-x);
}
int sum(int x)
{
	int ret = 0;
	while(x > 0)
	{
		ret += c[x];
		x -= lowbit(x);
	}
	return ret;
}
void add(int x, int d)
{
	while(x < N)   //特别注意
	{
		c[x] += d;
		x += lowbit(x); 
	}

}
int main ()
{

	while(scanf("%d", &n) != EOF)
	{
		memset(c, 0, sizeof(c));
		memset(ans, 0, sizeof(ans));
	    int x, y;
		for(int i = 0; i < n; i++)
		{
			scanf("%d %d", &x, &y);
			ans[sum(x+1)]++;
			add(x+1,1);
		}
		for(int i = 0; i < n; i++)
			printf("%d\n", ans[i]);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值