hdu 1551Cable master(二分)

Cable master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1602    Accepted Submission(s): 589


Problem Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
 

Input
The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0's.
 

Output
For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).
 

Sample Input
  
  
4 11 8.02 7.43 4.57 5.39 0 0
 

Sample Output
  
  
2.00
 
题目大意:
给定一些绳子的长度,共有N根,长度不一。现在要求在这些绳子中切割出K根长度相同的绳子。而且这些绳子的长度要尽可能的长。
解题思路:
在0和最长的绳子之间进行二分查找,关键的精度问题,妈蛋,wrong了十几遍才过的。
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
#define esp 1e-5
int cable[10010];
int n,k;
int Max;
int main()
{
    while(scanf("%d%d",&n,&k)&&n&&k)
    {
        Max=0;
        for(int i=0;i<n;i++)
        {
            double temp;
            scanf("%lf",&temp);
            cable[i]=(int)((temp+esp)*100);//注意处理方式
            if(Max<cable[i])
                Max=cable[i];
        }
        int left=0,right=Max,ans=-1;
        while(left<=right)
        {
            int mid=(left+right)/2;
            int sum=0;
            for(int i=0;i<n;i++)
                sum+=cable[i]/mid;
            if(sum>=k)
            {
                if(ans<mid)//找出尽可能长的
                    ans=mid;
                left=mid+1;
            }
            else right=mid-1;
        }
        if(ans==-1)
            printf("0.00\n");
        else
            printf("%.2lf\n",(double)ans/100.0);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值