poj 3041Asteroids+3692Kindergarten(二分图匹配+公式补充)

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13780 Accepted: 7493

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

问题描述
有一个N*N的网格,放有k个星星。

Bessie有一个强大的武器,每次可以清扫任意一行或者任意一列上所有的星星。当时武器非常昂贵,给出K个星星的位置,用最少的武器清扫干净所有的星星。

解题思路:
最小顶点覆盖:
用最少的顶点覆盖所有的边
二分图最小顶点覆盖 = 最大匹配

采用匈牙利算法:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
bool _map[520][520];
int vis[520];
int link[520];//记录n2中的点在n1中所匹配的点的编号,即匹配集合M
int n,k;
int n1,n2;//为二分图的两个顶点集
bool Find(int x)
{
    for(int i=0;i<n2;i++)
    {
        if(_map[x][i]&&!vis[i])//x和i有边,且节点i未被搜索
        {
            vis[i]=1;
            if(link[i]==-1||Find(link[i]))//如果i不属于前一个匹配M,或者i匹配的节点可以找到一条增广路
            {
                link[i]=x;//更新
                return true;
            }
        }
    }
    return false;
}
int mach()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0;i<n1;i++)
    {
        memset(vis,0,sizeof(vis));
        if(Find(i))//如果从第i个点找到了增广路
            ans++;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(_map,0,sizeof(_map));
        int r,c;
        for(int i=1;i<=k;i++)
        {
            scanf("%d%d",&r,&c);
            _map[r-1][c-1]=true;
        }
        n1=n2=n;
        printf("%d\n",mach());
    }
    return 0;
}

Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4798 Accepted: 2334

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

Source


问题描述:

在幼儿园中,有很多小孩,男孩之间互相认识,女孩之间也互相认识。而且,知道一些女孩男孩之间相互认识。现在老师要组织一个游戏,需要参加游戏的人之间相互认识。求老师可挑选参加游戏的最大人数。

题目分析:

这个题目相当于求最大团。下面我就来补充几个概念,和几个公式

1、独立集:任何两点都不相邻。

2、团:任何两点都相邻。

3、最大独立集 = 顶点数 - 最大匹配数

4、最小顶点覆盖 = 最大匹配数

5、最小路径覆盖 = 最大独立集

6、最大团 = 补图的最大独立集

下面就直接运用第六个公式,先构建一个补图,之后求最大匹配数。结果用顶点数一减就完事了。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
bool _map[300][300];
int vis[300];
int link[300];
int n1,n2;
int G,B,M;
bool Find(int x)
{
    for(int i=0;i<n2;i++)
    {
        if(_map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(link[i]==-1||Find(link[i]))
            {
                link[i]=x;
                return true;
            }
        }
    }
    return false;
}
int mach()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0;i<n1;i++)
    {
        memset(vis,0,sizeof(vis));
        if(Find(i))
            ans++;
    }
    return ans;
}
int main()
{
    int kase=1;
    while(scanf("%d%d%d",&G,&B,&M)&&G&&B&&M)
    {
        for(int i=0;i<G;i++)//构建原二分图的补图
            for(int j=0;j<B;j++)
                _map[i][j]=true;
        int g,b;
        for(int i=0;i<M;i++)
        {
            scanf("%d%d",&g,&b);
            _map[g-1][b-1]=false;
        }
        n1=G; n2=B;
        printf("Case %d: %d\n",kase++,G+B-mach());
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
应用背景为变电站电力巡检,基于YOLO v4算法模型对常见电力巡检目标进行检测,并充分利用Ascend310提供的DVPP等硬件支持能力来完成流媒体的传输、处理等任务,并对系统性能做出一定的优化。.zip深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值