MST - ZOJ - 1586 - QS Network- PRIM-邻接矩阵

大奶牛又开始写(发)题(代)解(码)了233333

QS Network

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


还是一道裸题(那你解释一下为什么你WA了五次) 

题意很简单(那你解释一下为什么你直接看了中文题目)

n个人之间信号传输,每两个人信号传输路的代价 = 路径的话费 + 两个人的话费

求花费最小,即MST


给了邻接矩阵就直接用PRIM算法去写了,刚开始的时候每次循环找出一条最小代价的时候,直接根据每次循环的当前最小路径的花费来算了。。。其实应该找根据路径话费 + 路径端点两个人的话费的最小来算。。。。。老是忘记。。改变顺序输入样例=。=  这样这个问题应该可以找出来。

然后这题每组数据不超过1000.。我就把最大路径max设成1010了。,。。忘记算上端点了。。。其实最小也应该是3001.。。

最近心情不好各种爆炸


#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<queue>
#define pb push_back
#define mp make_pair
#define LL long long
#define max3(x, y, z) max((x), max((y), (z)))
#define min3(x, y, z) min((x), min((y), (z)))
using namespace std;

const int N = 100010;

int ma[1005][1005];
int cost[N];
int n;

int Prim()
{
    int ans = 0;
    int lowcost[N];

    for(int i = 1; i <= n; i ++){
        lowcost[i] = ma[1][i];
    }
    lowcost[1] = -1;
    for(int i = 1; i < n; i ++){
        int v = 0;
        int minn = 3010;        ///!这里出了问题

        for(int j = 1; j <= n; j ++){
            if(lowcost[j] < 0) continue;
            if(minn > lowcost[j]){
                minn = lowcost[j];
                v = j;
            }
        }
        lowcost[v] = -1;
        ans += minn;
        for(int j = 1; j <= n; j ++){
            if(lowcost[j] < 0) continue;
            if(lowcost[j] > ma[v][j]){
                lowcost[j] = ma[v][j];
            }
        }
    }

    return ans;
}

int main()
{
    int ncase;

    scanf("%d", &ncase);
    while(ncase --){
        scanf("%d", &n);
        for(int i = 1; i <= n; i ++){
            scanf("%d", &cost[i]);
        }
        for(int i = 1; i <= n; i ++){
            for(int j=  1; j <= n; j ++){
                scanf("%d", &ma[i][j]);
                ma[i][j] = ma[i][j] + cost[i] + cost[j];	///直接在这里算上每条边的“真实”长度
            }
        }
        printf("%d\n", Prim());
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值