统计难题

统计难题

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131070/65535K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 2
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;
struct node
{
	int cnt;
	struct node* a[26];
};
node *head= (node *)malloc(sizeof(node));
int main()
{
	char ss[12];
	node *p;
	for(int i = 0; i < 26; i ++)
	   head->a[i] = NULL;
	while(cin.getline(ss,12,'\n'),ss[0]!='\0')
	{
		
	    p = head;
	    //cout << ss << endl;
		for(int i = 0; ss[i] != '\0'; i ++)
		{
			if(p->a[ss[i]-'a'] == NULL)
			{
				//cout << ss[i] << endl;
				p->a[ss[i]-'a'] = (node *)malloc(sizeof(node));
				p = p->a[ss[i]-'a'];
				for(int j = 0; j < 26; j ++)
				{
					p->a[j] = NULL;
				}
				p->cnt = 1;
			}
			else
			{
				//cout <<ss[i]<< endl;
				p = p->a[ss[i]-'a'] ;
				p->cnt ++;
			}
		}
	}
	while(scanf("%s",ss)!=EOF)
	{
		int i ;
		p = head ;
		for(i = 0; ss[i] != '\0'; i ++)
		{
			if(p->a[ss[i]-'a'] == NULL) break;
			else
			  p = p->a[ss[i]-'a'];
		}
		if(ss[i] == '\0')
		  printf("%d\n",p->cnt);
		else
		  printf("%d\n",0);
	}
	return 0;
}

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
struct node
{
	int a[26];
	int c ;
};
node data[4000 * 100];
char s[12] ;
int cnt = 1;
void insert()
{
	int root = 0;
	for(int i = 0; s[i]!='\0'; i ++)
	{
		if(data[root].a[s[i]-'a'] == -1)
		{
			data[root].a[s[i]-'a'] = cnt ++;
		}
		root = data[root].a[s[i]-'a'];
		data[root].c ++;
	}
}
int main()
{
	for(int i = 0; i < 4000 * 100; i ++)
	{
		data[i].c = 0;
		for(int j = 0; j < 26; j ++)
		 data[i].a[j] = -1;
	}
	while(cin.getline(s , 12 , '\n'),s[0] != '\0')
	{
		insert();
	}
	while(scanf("%s",s)!=EOF)
	{
		int root = 0;
		int i ;
		for(i = 0; s[i]!='\0'; i ++)
		{
			if(data[root].a[s[i]-'a'] == -1)
		    {
		    	printf("0\n");
		    	break;
		    }
		    root = data[root].a[s[i]-'a'];
		}
		if(s[i] == '\0')
		{
			printf("%d\n",data[root].c);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值