Common Subsequence

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 5
Problem Description
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n , m ;
int dist[2005][2005];
char str1[2005];
char str2[2005];

void dfs()
{
    for(int i = 1; i <= n; i ++)
        for(int j = 1; j <= m; j ++)
    {
        if(str1[i] == str2[j])
            dist[i][j] = dist[i-1][j-1]+1;
        else
            dist[i][j] = max(dist[i-1][j] , dist[i][j-1]);
    }
    /*for(int i = 1; i <= n; i ++)
    {
        for(int j = 1; j <= m; j ++)
        {
            cout << dist[i][j] <<" ";
        }
        cout << endl;
    }*/


}
int main()
{
    while(scanf("%s %s",str1+1 , str2+1)!=EOF)
    {
        n = strlen(str1+1);
        m = strlen(str2+1);
        for(int i = 0; i <= n; i ++)
            dist[i][0] = 0;
        for(int j = 0; j <= m; j ++)
            dist[0][j] = 0;
        dfs();
        printf("%d\n",dist[n][m]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值