http://poj.org/problem?id=1363

Rails
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24642 Accepted: 9662

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes
转载自《数据结构编程实验》。
试题分析:
   车站的铁路路线实际上是一个栈,A方向驶来的火车位初始序列【1,2,。。。。,n】;B方向驶出的火车位初始序列的一个置换,这个置换通过出入站操作实现。按照“先进先出”规则,置换中的任何元素x出栈前,所有大于x的元素必须出栈,栈内元素值必须小于x,因为大于x的元素后于x入栈,小于x的元素先于x入栈。设:
   
置换的合法标志为valid;
栈中或已出栈元素的最大值是max;
元素出入栈的标志序列为p,其中p【x】=
0   元素未入栈
1   元素已入栈
2   元素已出栈
 
计算过程如下:
1) 所有元素未入栈,即p中所有元素设为0,max=0;
2) 依次读如当前置换的每个元素x,按照下述办法判断置换是否合法。
在目前置换合法的情况下(valid = true):
。看栈中是否存在大于x的元素t。如果有(p【t】 == 1, x+1<= t <= max), 则按照后进先出规则,这些元素位于x的上方,x是无法出栈的,失败退出(valid = false)。
。调整栈中和已出栈元素的最大值(max = (max>x?max:x));
。所有小于x且未入栈的元素p【j】入栈(p【j】由0调为1,1<=j<=x-1)。
代码:
 
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000+10;
int p[maxn];
int n;
int main() {
    cin >> n;
    while (n) {
        int x, max=0;
        cin >> x;
        while (x) {
            bool valid = true;
            memset(p, 0, sizeof(p));
            for (int i = 1; i <= n; i ++) {
                if (valid) {
                    bool ok = true;
                    for (int j = x+1; j <= max; j ++) {
                        if (p[j] == 1) {
                            ok = false;
                            break;
                        }
                    }
                    if (!ok) {
                        valid = false;
                    } else {
                        if (max < x) max = x;
                        p[x] = 2;
                        for (int j = x-1; j >= 0 && !p[j]; j --) {
                            p[j] = 1;
                        }
                    }
                }
                if (i < n) cin >> x;
            }
            cout << (valid?"Yes":"No") << endl;
            cin >> x;
        }
        cout << endl;
        cin >> n;
    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值