Sequence II

Sequence II

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 410 Accepted Submission(s): 182


Problem Description
Long long ago, there is a sequence A with length n. All numbers in this sequence is no smaller than 1 and no bigger than n, and all numbers are different in this sequence.
Please calculate how many quad (a,b,c,d) satisfy:
1. 1a<b<c<dn
2. Aa<Ab
3. Ac<Ad

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case begins with a line contains an integer n.
The next line follows n integers A1,A2,,An .

[Technical Specification]
1 <= T <= 100
1 <= n <= 50000
1 <= Ai <= n

Output
For each case output one line contains a integer,the number of quad.

Sample Input
  
  
1 5 1 3 2 4 5

Sample Output
  
  
4
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 50005;
int n;
int C[maxn], c[maxn], a[maxn], b[maxn];

int lowbit(int i)
{
    return i&(-i);
}

int sum(int i)
{
    int res = 0;
    while (i > 0) {
        res += C[i];
        i -= lowbit(i);
    }
return res;
}

void add(int i)
{
    while (i <= n)
    {
        C[i] += 1;
        i += lowbit(i);
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while (t --)
    {
        scanf("%d", &n);
        memset(c, 0, (n+5)*sizeof(c[0]));
        memset(b, 0, (n+5)*sizeof(b[0]));
        memset(C, 0, (n+5)*sizeof(C[0]));
        for (int i = 1; i <= n; i ++) {
            scanf("%d", &a[i]);
            b[i] = sum(a[i]);
            add(a[i]);
        }
        memset(C, 0, (n+5)*sizeof(C[0]));
        for (int i = n; i >= 1; i --) {
            c[i] = sum(n)-sum(a[i])+c[i+1];
            add(a[i]);
        }
        __int64 res, t1, t2;
        res = 0;
        for (int i = 2; i <= n-2; i ++) {
            t1 = b[i];
            t2 = c[i+1];
            res += t1 * t2;
        }
        printf("%I64d\n", res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值