pat--1015

1015. Reversible Primes (20)时间限制 400 ms
内存限制 32000 kB
代码长度限制 16000 B
判题程序 Standard作者 CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:73 1023 223 10-2 Sample Output:YesYesNo

#include<stdio.h>
#include<math.h>
int IsPrime(int N)
{
   int i;
   if(N==1)
   return 0;
   else if(N==2)
   return 1;
   else for(i=2;i<N/2;i++)
   {if(N%i==0)
   return 0;}
   return 1;
}

int turn(int N,int D)
{
    int i,j;
 int a[100];
 int k;
 k=N;
 for(i=0;k!=0;i++)
 {
 a[i]=k%D;
 k=k/D;
 }
    k=0;
 i=i-1;
 for(j=0;j<=i;j++)
 k+=a[j]*(int)pow(D,i-j);
 return k;
}

int main(void)
{
   int a[1000];
   int i,j;
   int N,D;
   int flag;
   i=0;
   while(1)
   {
   scanf("%d",&N);
   if(N<0)
   break;
   else
   scanf("%d",&D);
   N=turn(N,D);
   flag=IsPrime(N);
   if(flag==0)
   a[i]=0;
   else
   a[i]=1;
   i++;
   }
   for(j=0;j<i;j++)
   {if(a[j]==0)
   printf("No\n");
   else printf("Yes\n");}
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值