HIHO_Disk Storage

#1100 : Disk Storage

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Little Hi and Little Ho have a disk storage. The storage's shape is a truncated cone of height H. R+H is radius of top circle and R is radius of base circle. 
Little Ho buys N disks today. Every disk is a cylinder of height 1. Little Ho wants to put these disk into the storage under below constraints:

1. Every disk is placed horizontally. Its axis must coincide with the axis of storage.
2. Every disk is either place on the bottom surface or on another disk.
3. Between two neighboring disks in the storage, the upper one's radius minus the lower one's radius must be less than or equal to M.

Little Ho wants to know how many disks he can put in the storage at most.

输入

Input contains only one testcase.
The first line contains 4 integers: N(1 <= N <= 100000), M, H, R(1 <= M, R, H <= 100000000).
The second line contains N integers, each number prepresenting the radius of a disk. Each radius is no more than 100000000.

输出

Output the maximum possible number of disks can be put into the storage.

样例输入
5 1 10 3
1 3 4 5 10

样例输出

4

解题思路

题目中存在的陷阱为:Between two neighboring disks in the storage, the upper one's radius minus the lower one's radius must be less than or equal to M.

题目中给出的是:

                       R(upper)-R(lower)<=M

这时,上层的半径是可以比下层的小的。

按照这种思想,我的解题思路为:

先对整个序列进行从小到大排序,然后从最大值往小值推,当找到第一个半径小于或等于R,记为k时,则可以确保1,2.....k-1都是可以成功放入的。只要找出k+1,k+2,.....n中满足条件的即可。

源码如下:

#include<iostream>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
int N,M,H,R=0;
int main(){
	cin>>N>>M>>H>>R;
	vector<int> data(N,0);
	for(int i=0;i<N;i++)
		cin>>data[i];
	sort(data.begin(),data.end());
	int count=0;
	int place=-1;
	for(int i=N-1;i>=0;i--){
		if(data[i]<=R){
			place=i;
			count++;
			break;
		}
	}
	if(place!=-1){
		int i=place;
		for(int j=i+1;j<N;j++){
			if(((data[j]-data[j-1])<=M)&&(data[j]<= j+R))
				count++;
			else
				break;
		}
		count=count+place;
	}
	cout<<min(count,H)<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值