GLFW在Qt中的配置问题

配置环境 vs2015 + Qt5.9

从官方下载glfw-3.2.1源代码后,通过Cmake默认配置,生成glew.sln,编译生成glfw3.lib,将其和include文件包含到Qt的pro文件中后,编译示例程序时,发生好多link错误:“error LNK2019: 无法解析的外部符号 - ”。
示例代码如下:

#include <GLFW/glfw3.h>
int main(int argc, char *argv[])
{
    glfwInit();
    glfwWindowHint(GLFW_CONTEXT_VERSION_MAJOR, 3);
    glfwWindowHint(GLFW_CONTEXT_VERSION_MINOR, 3);
    glfwWindowHint(GLFW_OPENGL_PROFILE, GLFW_OPENGL_CORE_PROFILE);
    //glfwWindowHint(GLFW_OPENGL_FORWARD_COMPAT, GL_TRUE);

    return 0;
}

解决办法:
在cmake时,将BUILD_SHARED_LIBS选项勾上,重新编译生成glfw3.libglfw3dll.dll,将其添加到Qt的pro中,可编译通过

阅读更多
文章标签: opengl glfw
个人分类: Qt
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭