POJ 3261 Milk Patterns(二分+后缀数组)

题目链接 :点击打开链接

Milk Patterns
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 12952 Accepted: 5757
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

题意:求至少出现K次的可重叠子串中最长子串长度

思路:二分+后缀数组,具体怎么实现看代码注释吧,个人觉得也不算很好理解,虽然是简单题但是在是否符合条件那一块自己也想了很久。但是多想想就明白了。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
int wa[20005],wb[20005],wv[20005],ws[20005];
int rank1[20005],height[20005];
int sa[20005],r[20005];int n,k;
int cmp(int *r,int a,int b,int l){
	return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(int *r,int *sa,int n,int m){
	int i,j,p,*x=wa,*y=wb,*t;
	for(i=0;i<m;i++) ws[i]=0;
	for(i=0;i<n;i++) ws[x[i]=r[i]]++;
	for(i=1;i<m;i++) ws[i]+=ws[i-1];
	for(i=n-1;i>=0;i--) sa[--ws[x[i]]]=i;
	for(j=1,p=1;p<n;j*=2,m=p){
		for(p=0,i=n-j;i<n;i++) y[p++]=i;
		for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
		for(i=0;i<n;i++) wv[i]=x[y[i]];
		for(i=0;i<m;i++) ws[i]=0;
		for(i=0;i<n;i++) ws[wv[i]]++;
		for(i=1;i<m;i++) ws[i]+=ws[i-1];
		for(i=n-1;i>=0;i--) sa[--ws[wv[i]]]=y[i];
		for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
			x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
	}
	return;
}
void calheight(int *r,int *sa,int n){
	int i,j,k=0;
	for(i=1;i<=n;i++) rank1[sa[i]]=i;
	for(i=0;i<n;height[rank1[i++]]=k)
		for(k?k--:0,j=sa[rank1[i]-1];r[i+k]==r[j+k];k++);
	return;
}
 int fun(int x)
{
    int i,maxn,minn=sa[1],cnt = 1;
    //如果cnt定义的是0,最后要加1,因为height数组的值是后一个和前一相同的个数,height[i],那答案至少就是2了。
    for(i=2;i<=n;i++)
    {
        if(height[i]>=x)//首先最长公共前缀肯定要大于现在枚举的长度
        cnt++;//看连续的到底有几个
        else
        cnt = 1;//前面height[i]>=x后面就小于x了,说明此时开始不连续,那么重现让cnt=1;
        if(cnt>=k)//次数超过了k,那么这个k长度下是可行的
        return 1;
    }
    return 0;
}
int main()
{
    int i;
    scanf("%d%d",&n,&k);
    int  max=0;
    for(i=0;i<n;i++)
    {
        scanf("%d",&r[i]);
        if(max<r[i]) max=r[i];
    }
    r[n]=0;
    da(r,sa,n+1,max+1);
    calheight(r,sa,n);
    int l=1,r=n,mid,ans;
    while(l<=r)
    {
        mid=(l+r)/2;
        if(fun(mid))
        {
            ans=mid;
            l=mid+1;
        }
        else r=mid-1;
    }//二分枚举长度
    printf("%d\n",ans);
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值