搜索 Q题


Q -  17
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

       
       
6 8
 

Sample Output

 Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8  5 2
2.解题思路:
  题意:意思是给你一个数n,要构成一个素数环,这个素数由1-n组成,要求选中环上的任意一个数字ii与它相连的两个数加起来都分别为素数,满足就输出。
  思路:本题为深搜题目,用深搜把每种情况遍历一遍。可以先对1n相加得到的数是否为素数进行预处理,然后从i=2开始进行DPS搜索。
#include<iostream>
#include<iomanip>
#include<cstring>
#include<cmath>
using namespace std;
int n,cnt = 1;
int vis[21],a[21];
int p[38] = {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1};
void dfs(int c)
{
    if(c == n && p[a[0] + a[n-1]])
    {
        cout << a[0] ;
        for(int i = 1;i < n;++i)
        cout << " "<< a[i];
        cout <<endl;
    }
    else for(int i = 2;i <= n;++i)
        if(!vis[i] && p[i + a[c-1]])
        {
            a[c] = i;
            vis[i] = 1;
            dfs(c+1);
            vis[i] = 0;
        }
}


int main()
{
    a[0] = 1;
    while(cin >> n)
    {
        memset(vis,0,sizeof(vis));
        cout << "Case " << cnt++ <<":"<<endl;
        dfs(1);
        cout << endl;
    }


    return 0;
}
       
       

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值