HDU 2795 线段树



Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23954    Accepted Submission(s): 9881


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
题意:以样例为例,给你一个高3宽5的画布,然后给你一个数n表明你要操作的次数,下边有n个数表示海报为高1宽x,往画布上贴的时候遵循了两个原则第一:尽量往上贴,第二,尽量往左贴输出你贴在了第几层。
思路:线段树,树的叶节点表示每一层,节点的内容存这一层还有的容量。不多说,自己在这里思考一下,应该已经很清楚了。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 200005

using namespace std;

struct node
{
	int left,right;
	int num;
}tree[N<<2];

int n,m,q;

void push_up(int i)
{
	tree[i].num=max(tree[i<<1].num,tree[i<<1|1].num);
	return ;
}

void build(int i,int left,int right)
{
	tree[i].left=left;
	tree[i].right=right;
	if(tree[i].left==tree[i].right)
	{
		tree[i].num=m;
		return ;
	}
	int mid=(tree[i].left+tree[i].right)>>1;
	build(i<<1,left,mid);
	build(i<<1|1,mid+1,right);
	push_up(i);
}

void update(int i,int x)
{
	if(tree[i].num<x)
	{
		printf("-1\n");
		return ;
	}
	if(tree[i].left==tree[i].right)
	{
		tree[i].num-=x;
		printf("%d\n",tree[i].left);
		return ;
	}
	int mid=(tree[i].left+tree[i].right)>>1;
	if(tree[i<<1].num>=x)
	{
		update(i<<1,x);
	}
	else
	{
		update(i<<1|1,x);
	}
	push_up(i);
}

int main()
{
	int x;
	while(scanf("%d %d %d",&n,&m,&q)!=EOF)
	{
		if(n>q) n=q;//这里需要考虑一下内存的事仔细想想,很容易看懂。
		memset(tree,0,sizeof(tree));
		build(1,1,n);
	while(q--)
	{
		scanf("%d",&x);
		update(1,x);
	}
	//for(int i=1;i<=6;i++) printf("%d %d %d\n",tree[i].left,tree[i].right,tree[i].num);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值