HDU 1829 A Bug's Life(带权并查集)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16887    Accepted Submission(s): 5402


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
题意: 测试样例ccase
n m
n个人 m个关系
m行
x y 表示x 和y 可以交配,问你有没有同性恋
思路 : 带权并查集
推荐一篇博客: 写的挺好的
http://simone-chou.iteye.com/blog/1930207
#include<stdio.h>
#define max 2000+5

using namespace std;

int f[max];
int rank[max];

int getf(int a)  
{  
    if(f[a]==a) return a;  
    int r=getf(f[a]);  
    rank[a]=(rank[a]+rank[f[a]])%2;  
    f[a]=r;
    return r;  
}

/*
int getf(int x)
{
    if(f[x]==x) return x;
    int fa=getf(f[x]);
    rank[x]=(rank[x]+rank[f[x]])%2;
    f[x]=fa;
    return f[x];
}*/


int merge(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1==t2)
    {
        if((rank[x]+rank[y])%2!=1) return 1;
        else return 0;
    }
    f[t2]=t1;
    rank[t2]=(rank[x]-rank[y]+1+2)%2;
    return 0;
}

int main()
{
    int i,kk;
    int n,m;
    int x,y;
    int ccase;
    scanf("%d",&ccase);
    for(kk=1;kk<=ccase;kk++)
    {
        scanf("%d %d",&n,&m);
        for(i=0;i<=n;i++){
            f[i]=i;
            rank[i]=0;
        }
    int flag=0;
    for(i=1;i<=m;i++)
    {
        scanf("%d %d",&x,&y);
        if(merge(x,y)) flag=1;
    }
    printf("Scenario #%d:\n",kk);
    if(flag) printf("Suspicious bugs found!\n\n");
    else printf("No suspicious bugs found!\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值